41520members
184569posts

Workplace Tech 5.9.3 / Workplace Tech Editor (EBO) Microsoft Security Updates required for Visio and Office

Workplace Tech 5.9.3 / Workplace Tech Editor (EBO) Microsoft Security Updates required for Visio and Office

Issue

WPT 5.9.4 and WPTE require certain Microsoft Security updates for Visio and for Office running on the host machines.

Issues currently observed:

  • Different and various functions in the fluent ribbon do not work or the ribbon does not appear.
  • Following error "Application compile failure during save operation" is seen when saving/compiling an application in WorkPlace Tech Editor

Product Line

EcoStruxure Building Operation, TAC IA Series

Environment

  • Visio 2010, 2013, 2016,(.msi install) Visio 2019 is not supported in the current 5.9.4 or EBO versions
  • Visio 2013, 2016 (subscription "Click to Run")
  • Office 2010, 2013, 2016 (.msi install)
  • Office 2013, 2016 (subscription "Click to Run")
  • Support for Workplace Tech 5.9.4 and Workplace Tech Editor

Cause

Interoperability of Visio and Office can cause problems with Workplace Tech and Workplace Tech Editor if these MS16-70 updates are not applied.  If the Office / Visio product is "Click to Run" the software has not been updated to the latest version.

Resolution

Install the updates from Microsoft Security Bulletin MS-16-70

Visio 2010 32 bit KB3114872       Office 2010  KB3115198 select 32 bit or 64 bit depending on what is installed

Visio 2013 32 bit KB3115020       Office 2013  KB3115173 select 32 bit or 64 bit depending on what is installed

Visio 2016 32 bit KB3115041       Office 2016  KB3115144 select 32 bit or 64 bit depending on what is installed

NOTE:  If the Visio or Office is "Click to Run" (subscription such as Office 365) rather then from a Microsoft Office .msi, the product should be upgraded by using the Update Options feature

Visio Updates.jpg

If you try and install the KB/.msi install patches, you will get this message

Visio Update_1.jpg

86% helpful (6/7)