Invite a Co-worker
Send a co-worker an invite to the Exchange portal.Just enter their email address and we’ll connect them to register. After joining, they will belong to the same company.
Send Invite Cancel
80810members
346875posts

SboRestProvider Get/Alarms not working

Solved
SteveGregory
Commander Commander
Commander
0 Likes
5
239

SboRestProvider Get/Alarms not working

I am having issues trying to use the Get/Alarms with with EBO 3.0.2.33 and SmartConnector 2.4.22. The SBO REST provider returns a HTTP 500 error "Code=InvalidData..." and the SOAP REST provider returns "Buld Retrieve for alarm is not allowed".

 

Other functions of the web service are working fine and this has worked fine on previous versions. Can anyone suggest anything? Screen shots attached.

 

SmartConnectorIssue8083.png

 

 

SmartConnectorIssue8084.png

Attachments

Accepted Solutions
JeffBowman
Schneider Alumni (Retired)
Schneider Alumni (Retired)
0 Likes
2
229

Re: SboRestProvider Get/Alarms not working

Hi Steve,

 

Just to finish up here, per our emails, it seems you actually wanted to use the /AlarmEvents endpoint and not the /Alarms endpoint. Is this all working correctly now?

 

Best Regards,

 

-Jeff

See Answer In Context

SteveGregory
Commander Commander
Commander
0 Likes
1
225

Re: SboRestProvider Get/Alarms not working

Yes it was actually the alarm events that I was after and that is working fine, thank you for pointing that out. However, should the GetAlarms still return something when using the CSP endpoint?

See Answer In Context

JeffBowman
Schneider Alumni (Retired)
Schneider Alumni (Retired)
0 Likes
0
220

Re: SboRestProvider Get/Alarms not working

Hi Steve,

 

In theory it should! I will need to look if there were any changes in CSP in 3.x that would cause this to fail when searching. It seems between releases they break the search mechanism, so I wouldn't doubt it, if it stopped working.

 

Best Regards,

 

-Jeff

See Answer In Context

5 Replies 5
JeffBowman
Schneider Alumni (Retired)
Schneider Alumni (Retired)
0 Likes
4
235

Re: SboRestProvider Get/Alarms not working

Hi Steve,

 

You are correct about the SOAP provider, it simply doesn't support getting alarm items in bulk.

 

However, the SBO provider should in theory work.. However, because the SBO Provider uses EBO's CSP protocol behind the scenes, it is very possible they changed something in the protocol, that would need to be addressed in the REST Provider. Would it be possible for you you to turn on the Csp Client logging in Smart Connector and tell me what it shows when you send this request when using the SBO provider (also set logging level to trace).

 

Best Regards,

 

-Jeff

SteveGregory
Commander Commander
Commander
0 Likes
3
232

Re: SboRestProvider Get/Alarms not working

See attached log file.

Attachments
JeffBowman
Schneider Alumni (Retired)
Schneider Alumni (Retired)
0 Likes
2
230

Re: SboRestProvider Get/Alarms not working

Hi Steve,

 

Just to finish up here, per our emails, it seems you actually wanted to use the /AlarmEvents endpoint and not the /Alarms endpoint. Is this all working correctly now?

 

Best Regards,

 

-Jeff

SteveGregory
Commander Commander
Commander
0 Likes
1
226

Re: SboRestProvider Get/Alarms not working

Yes it was actually the alarm events that I was after and that is working fine, thank you for pointing that out. However, should the GetAlarms still return something when using the CSP endpoint?

JeffBowman
Schneider Alumni (Retired)
Schneider Alumni (Retired)
0 Likes
0
221

Re: SboRestProvider Get/Alarms not working

Hi Steve,

 

In theory it should! I will need to look if there were any changes in CSP in 3.x that would cause this to fail when searching. It seems between releases they break the search mechanism, so I wouldn't doubt it, if it stopped working.

 

Best Regards,

 

-Jeff