Invite a Co-worker
Send a co-worker an invite to the Exchange portal.Just enter their email address and we’ll connect them to register. After joining, they will belong to the same company.
Send Invite Cancel
80793members
346846posts

EWS Server History Values in SmartConnector are showing incorrect value in EBO

SteveGregory
Commander Commander
Commander
0 Likes
4
392

EWS Server History Values in SmartConnector are showing incorrect value in EBO

I have a SmartConnector extension running in 2.5.4 with boolean type History records which appear correct when viewed in the SmartConnector portal, however; they are all reading 0 in EBO 4.0.1.86. See attached screen shot. 

Attachments
Tags (2)
4 Replies 4
ardak
Commander Commander
Commander

Re: EWS Server History Values in SmartConnector are showing incorrect value in EBO

Hi Steven,

 

I've tested this and it looks like there's an issue with boolean serialization. It will be looked at ASAP.

 

BR

Armend

Tags (1)
SteveGregory
Commander Commander
Commander
0 Likes
2
211

Re: EWS Server History Values in SmartConnector are showing incorrect value in EBO

Just wondering if there is any update on this issue?

Tags (1)
ardak
Commander Commander
Commander
0 Likes
1
205

Re: EWS Server History Values in SmartConnector are showing incorrect value in EBO

Hi Steve,

 

There's an issue in EBO where EBO's EWS client doesn't understand boolean trends from Smartconnector. I just got word that this will be fixed in 4.0.3. 

 

I'll probably add a "legacy serve" mode to Smartconnector that can be turned on to allow older EBO clients to be used. 

 

BR

Armend

Tags (1)
SteveGregory
Commander Commander
Commander
0 Likes
0
191

Re: EWS Server History Values in SmartConnector are showing incorrect value in EBO

Hi Ardak,

Thanks for the update. If you have a version with this fix, happy to try it out. 

Steve

Tags (1)