Issue
"Cannot paste. /tridium/props/error.properties#error.E_RC_TO_NODE" when trying to paste a Lon shadow object into the workspace of an UNC.
Environment
- Niagara R2
- UNC-410
- UNC-520
Cause
There could be two possible causes for the error message. One possible cause is that the Lon jar file which contains the shadow object was updated on the WorkPlace Pro PC, but the updated module was never installed to the UNC. The other possible cause is that the updated Lon nt jar file was not installed in the \nre\modules folder of the WorkPlace Pro PC.
Resolution
There are two things to look into. Perform both procedures 1 and 2 only if the lon nt jar was not installed/upgraded to the nre\module folder. If all of the Lon jars are installed/upgraded correctly (Lon nt jar file installed to nre\modules folder) on the WorkPlace Pro PC, then only procedure 2 needs to be performed.
Procedure 1
If the lon nt file was not installed/updated to the \nre\modules folder, use the following steps to do so. These steps assume that the updated Lon nt jar is already installed on the WorkPlace Pro PC, but not it was not installed to the nre\modules folder.
- Stop WorkPlace Pro.
- Open the Niagara\build\nt and copy the Lon jar
- Open the niagara\build\nre\module folder and rename the Lon jar in question “.old”.
- Paste the copied Lon jar to the module folder and restart WorkPlace Pro.
The module will now need to be upgraded to the UNC. See above steps for procedure.
Procedure 2
If the UNC Lon module has not been installed/updated to the UNC, use the following steps to do so.
- Open the Admin Tool.
- Open a connection to the UNC
- Select the "Installation" tab then click the [Installation Wizard] button.
- Select the "emb" folder in the "Select Distribution Directory" window then click [Install]
- In the "Niagara Remote Installation" window, select the "Configure Modules Only" radio button then click the [Next >] button.
- Verify that there is a checkmark in the "Upgrade/Add" column for the updated lon jar file.
- Click the [Next >] button to continue. Make sure that on the "Database Backup" screen that you do backup the existing database.
- Continue through the remaining steps and allow the upgrade to install and the station to restart.
You should now be able to paste the shadow object to the WorkspaceEditor view.