Learn about the Community. Join our Core Community to Get Started

Schneider Electric Exchange Community

Discuss and solve problems in energy management and automation. Join conversations and share insights on products and solutions. Co-innovate and collaborate with a global network of peers.

Register Now
Knowledge Base
cancel
Showing results for 
Search instead for 
Did you mean: 

YAML errors when attempting to run batch file to start the Mongo service during V3 on premise installation

Issue

Before installing Access Expert on premise server software, the Mongo DB must be installed and the Mongo service started, this requires creation and editing of a configuration file where the data and log directories are specified.

There have been many cases of YAML errors seen during V3 on premise installation when attempting to start the Mongo service.

Product Line

Access Expert

Environment

  • V3
  • Mongo DB

Cause

The YAML parser that reads the "mongo.cfg" file is very sensitive to the format of the configuration file including some very strict rules about spaces, double quotes and back slashes.

When editing the file, it helps to setup the text editor to display ALL characters which will show any hidden characters that might be causing a parsing error.

Resolution

 

  1. Space is needed between key and value pair.
  2. Enclose paths in double quotes.
  3. Double back slash required in Windows systems.
Tags (5)
Labels (1)
No ratings