Schneider Electric Exchange Community

Discuss and solve problems in energy management and automation. Join conversations and share insights on products and solutions. Co-innovate and collaborate with a global network of peers.

Register Now
Knowledge Base
cancel
Showing results for 
Search instead for 
Did you mean: 

Xenta Server firmware versus Vista Server versions

Issue

Does the Xenta Server firmware version have to match the TAC Vista Server version?

When upgrading Vista Server version does the Xenta Server need to be upgraded as well?

Product Line

TAC Vista

Environment

  • Xenta Servers
  • Xenta 511, 527, 701, 711, 721, 731, 913
  • Vista Server

Cause

This situation usually occurs when upgrading a site. After the Vista software has been brought up to the latest version, does each Xenta Server also have to have its firmware upgraded to match?

Resolution

Whenever possible it is best to have the Xenta Server firmware version match the Vista Server version. However, if this is not possible, then ensure that the Vista Server is always of a later version than the Xenta Server.

For example: a Vista 5.1.5 Server is okay with a Xenta 5.1.4 server, but a Vista 5.1.5 Server may not operate correctly with a Xenta 5.1.6 Server.

Upgrading the Xenta Server is not necessarily required depending on compatibility of the Xenta Server and Vista Server version as detailed in the release notice of the version of Vista software.

 

XBuilder Version Xenta Server Version TAC Vista Version
4.5.0 5.0.0 5.0.1 5.0.2 5.0.3 5.1.0 5.1.1 or later
1.6 2.4 Yes Yes Yes Yes Yes Yes Yes
5.0.0 5.0.0 No Yes Yes Yes Yes Yes Yes
5.0.1 5.0.1 No No Yes Yes Yes Yes Yes
5.0.2 5.0.2 No No No Yes Yes Yes Yes
5.0.3 5.0.3 No No No No Yes Yes Yes
5.1.0 5.1.0 No No No 1) Yes 1) Yes Yes Yes
5.1.1 or later 5.1.1 or later No No No 1) Yes 1) Yes 1) Yes Yes

1) To be able to use the TAC OP7 with Xenta 700 in existing 5.0.2 or 5.0.3 installations, TAC XBuilder 5.1.0 or later can be started from TAC Vista 5.0.2 or later. The Xenta 700 units must be upgraded to the same version as XBuilder.

NOTE: The compatibility of a NON-Xenta Server or a Xenta that is placed in an LNS network does not follow the above rules. These are strictly for an Xenta Server.


Consult the release notices for release software to identify defect corrections, new features, and potential changes in compatibility.

If the versions are compatible then the decision to upgrade is up to the user, scheduling, and access to the units in the event of a failed upgrade units are remote.

To upgrade a Xenta Server in Vista right click on the Xenta Server and select properties. Change the XBuilder Version property to the version of System Program and XBuilder being used.

 

Note: In a specific situation there has been issues with the Xenta Server password in the properties window in Workstation. In this situation the Workstation was at version 5.1.8, the Xenta server was upgraded to 5.1.9, and then the XBuilder project was downloaded to the Xenta Server again. The Xenta Server was offline in Workstation. When the properties window was opened, the Xenta server password was much longer then it should have been. By reentering the password and clicking Okay, the Xenta Server came back online.

Tags (4)
Labels (1)
No ratings
Contributors