Learn about the Community. Join our Core Community to Get Started

Schneider Electric Exchange Community

Discuss and solve problems in energy management and automation. Join conversations and share insights on products and solutions. Co-innovate and collaborate with a global network of peers.

Register Now
Knowledge Base
cancel
Showing results for 
Search instead for 
Did you mean: 

WebReports displays a blank white screen instead of data

Issue

When viewing WebReports within WorkStation or Internet Explorer the report data is not shown. All that is seen is a blank screen even though the menu items are still displayed (as shown in Figure 1 below).
WebReports-WorkStation.pngFigure 1:: Report viewed through WorkStation (Or Internet Explorer)
When viewing the same WebReport through a different browser, Chrome or Firefox the report displays correctly

WebReports-Browser.pngFigure 2:: WebReport viewed using other Browsers (such as Chrome and Firefox)

Product Line

EcoStruxure Building Operation

Environment

  • EcoStruxure Building Operation WebReports
  • EcoStruxure Building Operation WorkStation

Cause

The issue has only been seen with Internet Explorer since the other browsers appear to work. Since Building Operation WorkStation uses Internet Explorer as its internal browser, the problem is seen when displaying WebReports within WorkStation.


To confirm that this is the issue you can check the Windows Event Log contents (Application Log Warnings) related to:


<Provider Name="ASP.NET x.x.xxxxxxx.x" />

...

<Data>/LM/W3SVC/1/ROOT/SchneiderElectric/WebReports-1-131958191596842252</Data>
<Data>Full</Data>
<Data>/SchneiderElectric/WebReports</Data>
<Data>C:\Program Files (x86)\Schneider Electric EcoStruxure\Building Operation WebReports\WebReports\</Data>
<Data>CultureNotFoundException</Data>
<Data>Culture is not supported. Parameter name: culture 4096 (0x1000) is an invalid culture identifier. at System.Globalization.CultureInfo.InitializeFromCultureId(Int32 culture, Boolean useUserOverride) at Microsoft.Reporting.WebForms.ReportDataOperation..ctor(IReportServerConnectionProvider connectionProvider, Boolean requiresFullReportLoad) at Microsoft.Reporting.WebForms.HttpHandler.GetHandler(String operationType, IReportServerConnectionProvider connectionProvider) at Microsoft.Reporting.WebForms.HttpHandler.ProcessRequest(HttpContext context) at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() at System.Web.HttpApplication.ExecuteStepImpl(IExecutionStep step) at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)</Data>


Resolution

To correct this issue ensure that the Windows Regional Language, found in the Windows Control Panel matches between the Workstation PC and the Reports Server.

Tags (1)
Labels (1)
No ratings