Learn about the Community. Join our Core Community to Get Started

Schneider Electric Exchange Community

Discuss and solve problems in energy management and automation. Join conversations and share insights on products and solutions. Co-innovate and collaborate with a global network of peers.

Register Now
Knowledge Base
cancel
Showing results for 
Search instead for 
Did you mean: 

Upgrade path from version 1.0 to current version

Issue

Upgrade path from version 1.0 to a current version

Product Line

EcoStruxure Building Operation

Environment

SmartStruxure Versions 1.0, 1.1, 1.2, 1.3, 1.4, 1.5, 1.6, 1.7, 1.8, 1.9, 2.0, 3.0

Cause

Upgrade path from version 1.0 to current - version

Important - The upgrade process is sequential, for example, 1.1 to 1.2 to 1.3 to 1.4

The primary released versions were, Release Note Dates (approximate)

1.0.0.161  
1.1.0.362 Dec 2011
1.2.0.767 July 2012
1.3.0.938 Nov 2012
1.3.0.10100 SP1  
1.3.0.20011 SP2  
1.4.0.4020 Sept 2013
1.4.1.68-73 Oct 2013
1.5.0.532 July 2014
1.6.0.250 (RC) Dec 2014
1.6.1.5000 Feb 2015
1.6.2.27 Maintenance Release Jun 2016 see TPA-SBO-16-0003
1.7.0.255 (RC) July 2015
1.7.1.89 Oct 2015
1.7.2.29 Maintenance Release Jun 2016 see TPA-SBO-16-0003
1.8.0.244 (RC) Mar 2016
1.8.1.79-87 Jun 2016
1.9.1.95 Apr 2017
1.9.2.45 Maintenance Release Oct 2017
1.9.3.24 Maintenance Release April 2018
1.9.4.29 Maintenance Release April 2019
2.0.1.130 & 135 June 2018 (130(License, Workstation, Reports Server) 135 - Server (AS, ES, EC))
2.0.2.67 Maintenance Release

Sept 2018

2.0.3.45 Maintenance Release

Dec 2018

2.0.4.83 Maintenance Release

June 2019

3.0.1.104

May 2019

Resolution

It is most important to read the Release Notes and System Upgrade Reference Guide for each version you are upgrading to, as there are some special notes that only apply to some installation types.

Click Here for Release Notes
Click Here for Upgrade documentation

The Minimum upgrade path would be as below (See Release Notes for any special instruction)

  • 1.0.0.161
  • 1.1.0.362 See StruxureWare Building Operation v1.0 to v1.1 upgrade issues Appendix A
  • 1.1.0.1225 See Appendix A
  • 1.2.0.767 See Appendix A This version can be avoided by using 1.2.0.1412 if possible
  • 1.2.0.2207 (Hotfix) Available from PSS See also Appendix A
  • 1.3.0.938 see Upgrade path from version 1.0 to current version See also Appendix A
  • 1.3.0.10100 (SP1) (needed if runtime compatibility is required during upgrade)
  • 1.4.0.4020 or 1.4.1.68 (Only needed if runtime compatibility is required during upgrade) See Upgrading Automation Servers from 1.3 to 1.4
  • 1.5.0.532
  • 1.6.1.5000 See Upgrade to 1.5.0 or 1.6.0 fails
  • 1.7.1.89
  • 1.8.1.87 See Product Announcement 00471 Pre-Upgrade LON Add-On 1.7.1 to 1.8.x
  • 1.9.1.95 Possible to upgrade directly from v1.5, but carefully study the release notes and upgrade instructions
    • Option to 1.9.2.45 Upgrade options more limited with this version, only from v1.7, see the release note
    • Option to 1.9.3.24 Upgrade options more limited with this version, only from v1.7, see the release note
  • 2.0.1.130/135 Possible to upgrade directly from v1.5, but carefully study the release notes and upgrade instructions. NOTE the new License structure for v2.0.
  • 3.0.1.104 Possible to upgrade directly from v1.8, see the table in "System Upgrade Reference Guide" (3.1 System Upgrade Overview), but carefully study the release notes and upgrade instructions. NOTE the new Licenses for v3.0.

Appendix A - Upgrading from Specific 1.x Builds

Upgrade from R1.0.0.XXXX to R1.3 (via R1.1 and R1.2)

  1. Upgrade from 1.0.0.XXXX to 1.1.0.1225
  2. Upgrade from 1.1.0.1225 to 1.2.0.1412 (Do not use 1.2.0.767)
  3. Upgrade from 1.2.0.1412 to 1.3

Upgrade from R1.1.0.XXXX to R1.3 (via R1.2)

  1. Upgrade from 1.1.0.XXXX to 1.2.0.1412 (Do not use 1.2.0.767)
  2. Upgrade from 1.2.0.1412 to 1.3

Upgrade from R1.2.0.767 to R1.3

  1. Apply hotfix 1.2.0.2207
  2. Upgrade from 1.2.0.2207 to 1.3

NOTE: These hotfix builds are not available for download from the Extranet site, you will need to contact product support and request them

Tags (4)
Labels (1)
100% helpful (2/2)