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SmartStruxure license and TAC Vista license on the same PC

Issue

When SmartStruxure and TAC Vista is installed on the same PC, the license system for one of the products doesn't work properly and you get no license.

Product Line

EcoStruxure Building Operation, TAC Vista

Environment

Flexera license system

Cause

SmartStruxure and TAC Vista uses the same license system vendor and also the same vendor daemon. That causes a conflict, and a special configuration is needed.

Resolution

Disable TAC Vista's license server and host the TAC Vista licenses in the SBO license server.


  1. Stop and disable the service "TACLicenseServer". This is done through "services" (Start-->run-->services.msc) on the PC.
  2. Make sure the correct license setup is made for TAC Vista. Refer to No license after reboot when TAC Vista Server (TACOS) runs as a service for further explanation.
  3. Create a folder for the TAC Vista licenses as a subfolder in the SBO license server installation folder. Give it the name "licenses" and place all TAC Vista customer licenses here. Do not place demo licenses in this folder.
  4. Open the SBO license server web page (http://localhost:8888) preferably with Chrome or FireFox
  5. Click on "Administration"
  6. Sign in using "admin" as user name. If you have logged in before, use the password you have defined. If not, enter "admin" as password and create a password as indicated in step 6a and 6b.
    1. If it is the first time you log in, enter a new password and click "Save".
    2. If it is the first time you log in, now click "OK".
  7. Click on "Vendor Daemon Configuration"
  8. Click on "Administer"
  9. Click the field "License File or Directory" and enter the folder name "licenses" on a new line.
  10. Scroll down and click "Save"
  11. Restart the SBO license service (Building Operation 1.6 License Server)

Additional notes

If your TAC Vista license is locked to a dongle, you need to replace the SBO vendor daemon file (taclic.exe) with the on from the license server hotfix produced for TAC Vista 5.1.9. Please contact Product Support Services for assistance and refer to this article.

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