Issue
In a Niagara G3, when going from graphic to graphic via the IE browser a gray or white screen will be displayed and the browser will lock up. The number of screens viewable before this happens is random.
Environment
- Niagara G3
- Internet Explorer
Cause
The G3 Niagara software was designed to function using the standard JRE. Therefore, it will be necessary to disable a setting in the Java control panel if this symptom is experienced.
Resolution
- Go to Control Panel and click on Java to open the Java Control Panel.
- Click on the Advanced tab and then expand the Java Plug-in setting.
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Uncheck the box for "Enable next generation Java Plug-in (requires browser restart)" and click on Apply.
Note: In rare cases with very large graphics files the Java Console could show the following error: "java.lang.OutOfMemoryError: Java heap space". If this is experienced it is possible to adjust the Heap space.- Go to the Control Panel and click on Java to open the Java Control Panel.
- Click on the Java tab and click on the "view..." button to display the Java Runtime Environment Settings.
- For the Java version enabled you will need to add parameters to the "Runtime parameters". In the single case where this was necessary the Runtime parameters used were "-Xms128m -Xmx256m".
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After adjusting the Java Heap, clear out the wbapplet cache.
- Go to Windows Explorer - Local Disk C: - Documents and Settings - Your Admin folder
- Right click on the "niagara" folder and delete it.
- This folder and its subfolders and files will be recreated the next time you open the browser.