Schneider Electric Exchange Community

Discuss and solve problems in energy management and automation. Join conversations and share insights on products and solutions. Co-innovate and collaborate with a global network of peers.

Register Now
Knowledge Base
cancel
Showing results for 
Search instead for 
Did you mean: 

I/A Series R2 OPC integration to Gallagher OPC Data 3.0 Server

Issue

I/A Series R2 OPC integration to Gallagher OPC Data 3.0 Server

R2 is unable to discover the OPC objects. 

Environment

I/A Series R2 version r2.301.529 and higher

Cause

I/A Series R2 OPC client supports integration to OPC data access server versions 1.x and 2.x. It has not been tested for DA server 3.x. 

Resolution

I/A Series R2 OPC Client does not support integration to OPC DA Server version 3.x. However, in this particular case, the OPC objects can be added manually and the integration works. 

1. The OPC Server and group have been successfully discovered and added to the R2 station. 

 

2. However, the OPC Items are not shown when we run the ItemListManager. In the example below, the OpcClientStringInput objects have been manually added.

To manually add the OPC Items:

- Go to the Group's WorkPlace Editor.
- In WorkPlace Pro, in the local library, go to 'tridiumx' > ''opcClient' > ''objects'. 
- Select the objects you need, copy and paste it to the OPC Group folder WorkPlaceEditor.
- Go to the properties of the OPC objects and configure the OPCItemFullName

Tags (1)
Labels (1)
No ratings