New in the Community? Get started here

Schneider Electric Exchange Community

Discuss and solve problems in energy management and automation. Join conversations and share insights on products and solutions. Co-innovate and collaborate with a global network of peers.

Register Now
Knowledge Base
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Discover the Exchange Community Top members of July 
Discover the latest features your community has to offer: register to the webinar here

DCOM permissions resetting with a Remote Desktop restart

Issue

After the successful install of Continuum 1.9x users are receiving a DCOM Permission error when logging on to webClient.

The error seems to happen often however it is intermittent some times in a day others a week.

Product Line

Andover Continuum

Environment

  • MS Server 2008 Standard
  • Windows 7
  • Continuum 1.9x and 2.0
  • webClient
  • Remote Desktop

Cause

It appears that when ever a remote desktop connection is made on Windows 7 or Windows 2008 server the console gets locked.

It stays locked until the local session is restored with a logon.

Resolution

  1. Create a Bat file.
    ****************************************************************************************
    @echo off
    
    REM Restores session 0 to the "console".  Thus allows local machine
    REM to return to the service accounts desktop without being locked.
    REM ------------------------------------------------------
    
    tscon.exe 0 /dest:console
    @%windir%\System32\tscon.exe 0 /dest:console
    @%windir%\System32\tscon.exe 1 /dest:console
    @%windir%\System32\tscon.exe 2 /dest:console
    
    ****************************************************************************************
  2. Place this file on the desktop of the Web Server system.
  3. When you disconnect from the remote session run this Bat file. Do not just disconnect. This must be run "As an Administrator." This will disconnect the session and restore the console.
Tags (6)
Labels (1)
No ratings