New in the Community? Get started here

Schneider Electric Exchange Community

Discuss and solve problems in energy management and automation. Join conversations and share insights on products and solutions. Co-innovate and collaborate with a global network of peers.

Register Now
Knowledge Base
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Discover the Exchange Community Top members of July 
Discover the latest features your community has to offer: register to the webinar here

Capture a Modbus trace log in EBO/SBO

Issue

  • How can I troubleshoot a communication issue with the Modbus protocol
  • Is there a log available within the AS or ES that shows the Modbus communication between Modbus devices

Product Line

EcoStruxure Building Operation

Environment

  • Building Operation Workstation
  • Building Operation Automation Server
  • Building Operation Enterprise Server

Cause

When troubleshooting Modbus issues in an AS or ES it can be helpful to see the communication between devices to help identify this issue. The trace log within both server types is available and is configured as described below in the resolution.

Resolution

  1. Open Workstation and navigate to [AS/ES name]/System/Modules/Trace/Loggers/nsp/nsp.pin.
  2. Right-click "nsp.pin.modbus" and choose Properties.
  3. Under Level, change from "Information" to "Trace", then click ok.
  4. Let it run a few minutes. If there are some user input needed to recreate the Modbus issue, then perform these steps now.
  5. Retrieve the log by right-clicking [AS/ES name]/System/Modules/Trace/TraceSettings and choose Trace settings->Get trace log
  6. Save the log file.
  7. A useful tool available on the Community, the Modbus decoder can be used to assist in viewing/debugging the Modbus trace log file information saved in the previous step.
  8. Once debugging is complete remember to change log level back to "Information" (reverse of step 3).
Tags (3)
Labels (1)
100% helpful (2/2)