Learn about the Community. Join our Core Community to Get Started

Schneider Electric Exchange Community

Discuss and solve problems in energy management and automation. Join conversations and share insights on products and solutions. Co-innovate and collaborate with a global network of peers.

Register Now
Knowledge Base
cancel
Showing results for 
Search instead for 
Did you mean: 

Automation Servers ignore time sync message sent from Windows NTP server that uses local internal clock

Issue

After configuring the system per Setting up a Local / Internal NTP Server the Automation Servers time would not sync to local NTP computer's time. Wireshark capture shows a 'Root Dispersion' greater than 10 seconds.

In the screen shots below, 10.169.90.13 is an Automation Server (NTP client) and 10.169.90.6 is the NTP server

CLIENT REQUEST

NTPClientUnSync.PNG

SERVER REPLY

NTPServerUnSync.PNG

This behavior of adding 10 seconds to the root dispersion is only observable when you are using the internal clock otherwise it is 0. This appears to be the intended behavior by Microsoft so that this NTP server would rank lower if using multiple NTP servers that might have more reliable time.

Product Line

EcoStruxure Building Operation

Environment

  • Automation Server
  • AS
  • Network Time Protocol
  • NTP

Cause

The NTP client in the AS ignores the time sent by the NTP server if the root dispersion is greater than 'X' seconds (not known at this time)

Resolution

In the Windows registry of the of machine being used as the time server, make the following change.... 

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W32Time\Config\LocalClockDispersion

The default for this key is “A” in hex. Change this to “0” and then restart the Windows Time service. You can do this by running the following command net stop w32time && net start w32time.

Here is what Wireshark shows after the time has been synchronized.

NTPClient_IN_Sync.PNG

SERVER REPLY

NTPServer_IN_Sync.PNG

Tags (3)
Labels (1)
100% helpful (1/1)