New in the Community? Get started here

Schneider Electric Exchange Community

Discuss and solve problems in energy management and automation. Join conversations and share insights on products and solutions. Co-innovate and collaborate with a global network of peers.

Register Now
Industry Automation and Control Forum
This forum is addressing industrial automation design & engineering, operations, asset performance, cyber security and digital transformation for Plants & Machines.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Crewman

Problems using TM3DM8R-module TM3 - 8 IO relays

Hi community, I have trouble using this product, because the green LED does not indicate

when I connect one input end and its common to 24Vdc and the corresponding output does have

the so called relay output when checking continuity.

 

Thank you for input in advance.

 

 

 

 

Link to the product TM3DM8R page: https://www.se.com/hk/en/product/TM3DM8R/module-tm3---8-io-relays/

6 REPLIES 6
Highlighted
Administrator

Re: Problems using TM3DM8R-module TM3 - 8 IO relays

Hey @JackieChen  , thank you for your question
 
I moved it to this forum where the community of experts will be able to provide you the right support and solve your issue! 
 
PS: don't hesitate to check the Knowledge base and use the search bar with keywords. there is a lot of content discussed everyday and your issue may have already been solved 😉

 

 

Oma
Exchange SE Global Community Manager
Community user guide  |   FAQ

Highlighted
Lieutenant JG

Re: Problems using TM3DM8R-module TM3 - 8 IO relays

To confirm, you have your wiring as indicated in the diagrams below, with the -ve terminal of the 24VDC power supply wired to the COM0 terminal, the +ve of the 24VDC power supply providing voltage to your 'sensor' and then the sensor output wired to the input terminal (I0 through I3)?

 

If you bypass the sensor, and directly wire the +ve terminal from the 24VDC power supply to I0 does an LED illuminate then?

 

I assume that you do have the TM3DM8R installed within a rack, with a 'receiver'/'controller' in that rack supplying the 5V operating voltage for the IO card itself.

 

And when you drive the Q0 through Q3 outputs from your PLC, does the LED for the associated output turn on?

 

2020-02-12 08_08_08-Modicon TM3 - Digital I_O Modules - Hardware Guide.png


Lead Control Systems Engineer for Alliance Automation (VIC).
All opinions are my own and do not represent the opinions or policies of my employer, or of my cat..
Highlighted
Crewman

Re: Problems using TM3DM8R-module TM3 - 8 IO relays

Sorry, I don't know what sensor is, the wiring diagram just shows as a switch to me.

Also what's the 5V rack? There's no mention about that in this datasheet: https://docs.rs-online.com/8a48/0900766b8150cd45.pdf

 

Do you mean that white socket for the 5V power supply? I thought it's for expansion module?

InkedCapture_LI.jpg

 

Highlighted
Lieutenant JG

Re: Problems using TM3DM8R-module TM3 - 8 IO relays

There is definitely a mention of the 5V rack / bus connection in the datasheet.

 

2020-02-12 13_29_29-0900766b8150cd45.pdf.png

The IO module simply will not work unless it is installed within a rack, and at this stage you haven't provided any indication that you have indeed installed it within a rack, nor that you have a PLC to control this IO module.

 

Please provide photo(s) that show your current installation, including the 24VDC Power Supply, the connections to your processor/PLC, the connections to your TM3DM8R IO Module, and the connections to your 'switch' or sensor.

 

These photos should be clear enough to identify EXACTLY which terminals the connections are made to, and EXACTLY which part numbers are in use for the PLC/IO Module.


Lead Control Systems Engineer for Alliance Automation (VIC).
All opinions are my own and do not represent the opinions or policies of my employer, or of my cat..
Highlighted
Crewman

Re: Problems using TM3DM8R-module TM3 - 8 IO relays

So is it connected via bus connector to the white socket?

Currently, I haven't installed in rack nor have PLC control yet.

Thank you for your replies, I guesss I understand what I am missing.

Highlighted
Lieutenant JG

Re: Problems using TM3DM8R-module TM3 - 8 IO relays

That plug is indeed what is supposed to connect this IO Module into the 'bus' of the other IO Modules / CPU.

The CPU is what is responsible for reading the inputs from this module, and driving the bits for the outputs.

 

The module itself (without a CPU to control it) is quite useless.

 

Once you have the CPU etc configured if you have another problem, please raise this as a separate topic here.

And given it sounds like at least one of my responses has 'solved' your problem, please mark one as the solution here.


Lead Control Systems Engineer for Alliance Automation (VIC).
All opinions are my own and do not represent the opinions or policies of my employer, or of my cat..