43429members
217967posts

M340 Firmware Version Compatibility with Unity Pro

Highlighted
Crewman

M340 Firmware Version Compatibility with Unity Pro

Hello everyone,

 

We are getting a new M340 PLC and I'm not sure what firmware version it has installed. We also have Unity Pro v6 which may not be updated for the time being. Will Unity Pro v6 work with later firmware versions of the M340? Are there any unknown issues?

 

Cheers

2 REPLIES 2
Highlighted
Commander

Re: M340 Firmware Version Compatibility with Unity Pro

I did think that this had been discussed before on the forum.

 

The firmware is generally backwards compatible, however you should realise that it will not be extensively tested in such a configuration.  So you will be taking on some additional risk in having a wide difference between the controller firmware and the project version.

 

BUT, I would very much NOT recommend you trying to force downgrade controller firmware.  This is almost always a surefire way of bricking a PLC.  Often hardware revisions are made which are NOT supported in older firmware.

 

If you are currently on Unity Pro v6, then you have an unsupported platform.  Prudent risk management would see you rapidly putting in place a process to get back into a supported version of Control Expert (the new branding for Unity Pro).

 

NOTE: I believe in Control Expert certain legacy products (i.e. Quantum etc) are starting to be dropped from support.  So you would want to take that into account with any migration process.  Of course if you still have a large range of now unsupported hardware devices this needs to be factored into the same risk management processes... and you should be looking to develop a process to replace these with supported devices.


Lead Control Systems Engineer for Alliance Automation (VIC).
All opinions are my own and do not represent the opinions or policies of my employer, or of my cat..
Tags (1)
Highlighted
Crewman

Re: M340 Firmware Version Compatibility with Unity Pro

Thanks for your help!

Tags (1)