New in the Community? Get started here

Schneider Electric Exchange Community

Discuss and solve problems in energy management and automation. Join conversations and share insights on products and solutions. Co-innovate and collaborate with a global network of peers.

Register Now
Geo SCADA Expert Forum
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Lt. Commander

[import] WebX Hand Control @not well-formed (invalid token)@ error

>>Message imported from previous forum - Category:ClearSCADA Software<<
User: tcookson, originally posted: 2018-11-13 17:35:20 Id:317
I'm having an issue similar to, but not exactly like, the one described here: https://www.schneider-electric.us/en/faqs/FA275742/

If I follow the the FAQ note and add port 81, then mimics no longer display. In my case alarms/events/mimics all display correctly, but when I Hand Control a test internal point through WebX I get an error pop-up "not well-formed (invalid token)". WebX has control privileges in the web test folder, including the mimic I'm writing from and the point I'm trying to hand control.

System is ClearSCADA 2017 (Sept '17 update), running on Windows Server 2012.


Reply User: BevanWeiss, posted: 2019-01-03 21:59:34
Why would you change this from port 80 to port 81?
What port numbers (HTTP/HTTPS) is your WebX using?
NOTE: The FAQ is for "A common cause of these errors is the Original WebX being configured to use custom secure or non-secure ports". If you are not using 'custom secure or non-secure ports' then you should not have followed the directions in your link.


Reply User: geoffpatton, posted: 2019-01-04 14:56:00
check the server configuration's WebX section and make sure Allow writes over HTTP is checked.


Reply User: tcookson, posted: 2019-04-02 23:37:33
The check box states "Allow logon and database writes over ****non-secure ****HTTP.

I'd much prefer HTTPS, if possible.


Reply User: sbeadle, posted: 2019-04-03 08:05:28
Client to web server communications are either HTTP or HTTPS, as configured within IIS. Web Server to ClearSCADA server communications are also configurable using HTTP or HTTPS, as configured in the IIS settings (referred in the FAQ) and Server Config tool WebX settings combined.
You can check the ClearSCADA server web port comms by enabling the WebX logging types in Server Status and reading the dbserver log files.


Reply User: adamwoodland, posted: 2019-04-04 01:27:38
http://resourcecentre.controlmicrosystems.com/display/CS/Diagnosing+Scripting+Connection+Errors may also help with your problem