New in the Community? Get started here

Schneider Electric Exchange Community

Discuss and solve problems in energy management and automation. Join conversations and share insights on products and solutions. Co-innovate and collaborate with a global network of peers.

Register Now
Geo SCADA Expert Forum
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Lt. Commander

[import] Trying to upgrade an external program to work with 2017

>>Message imported from previous forum - Category:ClearSCADA Software<<
User: geoffpatton, originally posted: 2019-02-28 23:13:29 Id:373
Ok guys again our loss of our head programmer is haunting us again. Our new programmer is also busy on other stuff.
My boss asked me to get a program working with 2017 R3 and something has changed.
We thought it would really be a quick recompile against the new version of ClearSCADA, since the program works with 2015 R2

In Visual Studios C#
The code is referencing SE.Scada.ViewX.exe
here is the section of code.
SchneiderElectric.Scada.ViewX._Application_ xView = new SchneiderElectric.Scada.ViewX._Application_();
xView_.Logon("MAIN", textBox_User.Text, textBox_Password.Text);
xView_.Visible = true;
SchneiderElectric.Scada.ViewX._Mimic _TemplateGraphic = (SchneiderElectric.Scada.ViewX._Mimic_)xView.Mimics.OpenFromServer(true, "MAIN", DM.FullName);

Application and Mimic are showing underlined in red, don't exist. I tried changing Application to App but that made other things show underlined in red.

Anyone have any advise?


Reply User: adamwoodland, posted: 2019-03-01 00:47:51
Have you added the relevant import statements?


Reply User: JesseChamberlain, posted: 2019-03-01 01:31:20
Also make sure you use an Update newer than October.


Reply User: geoffpatton, posted: 2019-03-01 14:22:14
Adam this is from a working program for 2015 R2.
The only change I made was to set the program to use dot net 4.5.2 it was on 4.5.1


Reply User: BevanWeiss, posted: 2019-03-02 01:00:14
Does your current development machine have ClearSCADA ViewX installed so that the references are correct?
It's possible the original developer didn't include the referenced DLL (and I'm surprised that it's an EXE in your 'code is referencing' statement) in the project files, so you'd need to use your version from your ClearSCADA install.


Reply User: tfranklin, posted: 2019-03-04 13:40:11
we ran into a string of issues with 2017R2 releases prior to october where .OpenFromServer would throw an error. That was eventually fixed but then the save command would throw an error. Everything seemed to be working fine in Nov-Jan of 2017R2. I'll try recompiling in a 2017R3 environment and see if the issue has cropped back up.

Out of curiosity -- what version of 2017R3 are you using? Release notes for the latest Feb 19 suggested something about all DLLs and plugins being renamed or relocated.

--ViewX dlls now all build and install into the same directory as the ViewX executable, plugins are differentiated with the naming convention of *.Plugin.dll

Not sure if that has anything to do with it. /shrug.


Reply User: geoffpatton, posted: 2019-03-05 15:26:52
Yes ViewX is installed.
The initial release of 2017R3 is what I used, I already had it installed on a VM.


Reply User: geoffpatton, posted: 2019-06-03 21:52:16
Just to wrap this thread up. We figured out the dll was one that our late programmer created. Once we got and used that it worked. So for the moment we are good. Our current programmer remembered seeing him create a dll for another application. So he started looking through all the saved files for the program and found the dll. We are not sure how he made the dll but that is a different problem for another time.