New in the Community? Get started here

Schneider Electric Exchange Community

Discuss and solve problems in energy management and automation. Join conversations and share insights on products and solutions. Co-innovate and collaborate with a global network of peers.

Register Now
Geo SCADA Expert Forum
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Admiral

[Imported] ScxV6Server.Connect error "SetClientDetails Failed"

>>Message imported from previous forum - Category:ClearSCADA Software<<
User: nminchin, originally posted: 2019-08-20 08:08:29 Id:487
Hi,

I have an excel tool that we've been using for years to do bulk changes, but recently trying it in ClearSCADA 2017, I'm getting this error when attempting to simply connect to the ScxV6Server object.

`SetClientDetails Failed`

I can't find any info on this error anywhere, any ideas?

1 REPLY 1
Admiral

Re: [Imported] ScxV6Server.Connect error "SetClientDetails Failed"

>>Responses imported from previous forum


Reply From User: nminchin, posted: 2019-08-20 22:18:03
Hmm, I can't edit my OP... I just wanted to clarify:
The error occurs on this line
`ScxV6Server.Connect(system, user, pass)`
Where the 3 arguments are actual values for my live running system.

 

Reply From User: JesseChamberlain, posted: 2019-08-21 04:09:27
Check the DB log, it should give you something more descriptive.

There will be SetClientDetails( IN: and SetClientDetails( OUT: lines with the actual parameters and the result.


Reply From User: nminchin, posted: 2019-08-21 04:41:40
Thanks Jesse.

I've attached what I think are the relevant lines, but not sure..

```
21-AUG-2019 04:36:03.143 1188 [SVR] Accepted connection 7 from 127.0.0.1:49812 to 127.0.0.1:5481 on socket 0xa38...
21-AUG-2019 04:36:03.143 1188 [SVR] ... Connection 7: Type 1, client version 0x64F1A29 (6.79.6697), (Uncompressed,Floating License,Include Checksums)
21-AUG-2019 04:36:03.143 1188 [SVR] ... Connection 7: confirmed, link version 6.79.6697, client name 'IP 127.0.0.1, Session 1'
21-AUG-2019 04:36:03.143 1188 [SCX] Server link attached to socket 0xa38
21-AUG-2019 04:36:03.143 1188 [SCX] Unconnected dedicated link requested, creating new parent link (Id = 97)
21-AUG-2019 04:36:03.143 1188 [PL97] Creating dedicated link
21-AUG-2019 04:36:03.143 1188 [PL97] Attaching to socket 0xa38
21-AUG-2019 04:36:03.143 1188 [SVRTHR] 1 AddClient from 127.0.0.1:49812, link is [SCX] 1:15
21-AUG-2019 04:36:03.143 1188 [SCX] 1:15 QP Created
21-AUG-2019 04:36:03.143 052C [SCX] 1:15 InitSecureSession( IN: )
21-AUG-2019 04:36:03.143 052C [SCX] 1:15 Found matching certificate for connection to local IP address 127.0.0.1
21-AUG-2019 04:36:03.143 052C [SCX] 1:15 InitSecureSession( OUT: hr 0 - Ok. )
21-AUG-2019 04:36:03.144 052C [SCX] 1:15 StartSecureSession( IN: )
21-AUG-2019 04:36:03.144 052C [SCX] 1:15 StartSecureSession( OUT: hr 0 - Ok. )
21-AUG-2019 04:36:03.144 0F10 [SCX] 1:15 Entering secure session
21-AUG-2019 04:36:03.144 052C [SCX] 1:15 SetClientDetails( IN: LoggedOn 0, IsLocal 0, User "", Workstation Name "", Client Name "Unknown" )
21-AUG-2019 04:36:03.144 052C [SCX] 1:15 SetClientDetails( OUT: Hr 0 - Ok. )
```

Also attached the file itself.

Cheers!

Attached file: (editor/qs/2moj3739m9y9.log), DB_001 (1).log File size: 839986


Reply From User: JesseChamberlain, posted: 2019-08-22 01:57:48
That does look like the relevant lines. Here's what it looks like when I do it:

22-AUG-2019 00:11:52.355 0374 [SCX] 8:08 QP Created
22-AUG-2019 00:11:52.355 29CC [SCX] 8:08 InitSecureSession( IN: )
22-AUG-2019 00:11:52.356 29CC [SCX] 8:08 Found matching certificate for connection to local IP address 127.0.0.1
22-AUG-2019 00:11:52.356 29CC [SCX] 8:08 InitSecureSession( OUT: hr 0 - Ok. )
22-AUG-2019 00:11:52.356 29CC [SCX] 8:08 StartSecureSession( IN: )
22-AUG-2019 00:11:52.356 29CC [SCX] 8:08 StartSecureSession( OUT: hr 0 - Ok. )
22-AUG-2019 00:11:52.356 0AD8 [SCX] 8:08 Entering secure session
22-AUG-2019 00:11:52.357 29CC [SCX] 8:08 SetClientDetails( IN: LoggedOn 0, IsLocal 0, User "", Workstation Name "", Client Name "Unknown" )
22-AUG-2019 00:11:52.357 29CC [SCX] 8:08 SetClientDetails( OUT: Hr 0 - Ok. )
22-AUG-2019 00:11:52.357 0AD8 [SCX] 8:08 SetClientDetails( IN: Lcid 0xFFFFFFFF, ClientName WTAULVSE0C7BFPL::ScxV6Server )
22-AUG-2019 00:11:52.357 0AD8 [SCX] 8:08 SetClientDetails( OUT: Features 0x8C0F, hr 0 - Ok. )
22-AUG-2019 00:11:52.357 0AD8 [SCX] 8:08 AdviseState( IN: )
22-AUG-2019 00:11:52.357 0AD8 [SCX] 8:08 AdviseState( OUT: hr 0 - Ok. )
22-AUG-2019 00:11:52.360 0AD8 [SCX] 8:08 Advise( IN: Port 5503, ClientId 2 )

So it seems to not be doing the second SetClientDetails for some reason...

If you'd like us to look at it further please raise a support ticket.