[Imported] CS 2017 R3 WebX trends are not displayed


[Imported] CS 2017 R3 WebX trends are not displayed

>>Message imported from previous forum - Category:ClearSCADA Software<<
User: Alexey, originally posted: 2019-07-02 08:17:28 Id:462
Good day.
When attempting to display trends through WebX using the configured Trend, the following fact was detected. When the sum of the number of characters in the full name of the signals exceeds a certain maximum number, the web page does not display the Trend component. Has anyone encountered a similar situation?


Re: [Imported] CS 2017 R3 WebX trends are not displayed

>>Responses imported from previous forum

Reply From User: geoffpatton, posted: 2019-07-02 18:24:04
Well in 2017 R2 I could not replicate it. I could still get trends on a Trend object and from selecting Display Historic Trend from the object menu on a mimic.
There is a limit of 254 characters to a FullName and you can only have 15 objects deep. I had 14 folder groups and then the point, trend, and mimic were at the 15th level. The full name was 254 characters. Then I tried with 3 folder groups and named them 63 characters long which is the name character limit. The Point, Mimic and Trend names were limited to 62 characters to stay at 254 total. the Name actually includes the "." so its total size limit is 64 characters for the name of an object as long as it will not cause the FullName to exceed 254. Anyway I still had 254 characters and could see the trends.

2010 is really old now is probably a good time to upgrade.

Reply From User: Alexey, posted: 2019-07-03 06:41:25
Hello. I use R3 May 2019, but it was discovered on R2 July 2018. You are right about 254 characters in total. But I have a problem with the total number of all characters in all full names of the database items displayed on the Pre-Configured Trends. For example, full name 1 has 200 characters, full name 2 is 180 characters ... full name N 210, etc., when FN1 + FN2 + ... + FN (n) is greater than a certain number, WebX does not display Pre- Configured Trend, only a blank web page.
For example, I attached a working config (R3 May 2019). If you add a letter (for example, "A") or a digit to the name of any instance, WebX stops displaying Pre-Configured Trends.
WebX login: operator, psswd: 2222222222

P.S. I am forced to use the national alphabet in the name of the database elements, and in my case the maximum number of characters at which everything works less than when using the Latin alphabet

Attached file: (editor/ev/8fcut782z8xa.zip), test_cfg.zip File size: 6746

Reply From User: geoffpatton, posted: 2019-07-03 14:10:03
Ah your tag says ClearSCADA 2010 R3.1
I only tried the original WebX.
I suspect you are using the new WebX that has the HTML5 Trend display.
I currently don't have any version of 2017 with the new WebX setup on anything so I do not have a test environment.
Being that you are on the latest I would contact your local support and have them check into it. It honestly sounds like something the Developers will have to address.