41333members
184398posts

CIFS mount error

Highlighted
Ensign

CIFS mount error

Hi team,

 

we are trying to configure a remote drive folder in ITA 9.0.4 with CIFS protocol and it does not work. We have the same parameters configured in DCE and it works properly, but in ITA we receive this error:

 

Failed to save mount : Mount failed :

mount error(5): Input/output error
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

Thanks

7 REPLIES 7
Highlighted

Re: CIFS mount error

Hi!

 

This error can be caused by incorrect hostname or security settings.

You can try to use sec=ntlm (it depends of environment) option:

 

mount -t cifs -o username=user,password=opensesame,sec=ntlm //myserver.com/myshare /mnt/myserver

 

 

sec=
Security mode. Allowed values are:
none attempt to connection as a null user (no name)
krb5 Use Kerberos version 5 authentication
krb5i Use Kerberos authentication and forcibly enable packet signing
ntlm Use NTLM password hashing (default)
ntlmi Use NTLM password hashing and force packet signing
ntlmv2 Use NTLMv2 password hashing
ntlmv2i Use NTLMv2 password hashing and force packet signing
ntlmssp Use NTLMv2 password hashing encapsulated in Raw NTLMSSP message
ntlmsspi Use NTLMv2 password hashing encapsulated in Raw NTLMSSP message, and force packet signing

Highlighted
Ensign

Re: CIFS mount error

Hi @Valentin_Kozlov 

 

I have tried with the command you suggested and I receive the error attached.

 

I think the security it has to be NTLM, because the same destination server with that configuration works with DCE.

 

Thanks

error cifs.jpg

 

 
 

 

Highlighted
Lieutenant JG

Re: CIFS mount error

Hello, give this format a try from your server. This worked for me from my ITA server to mount a windows share on "/mnt".

 

mount.cifs  \\\\<servername>\\<share> /mnt  -o user=<windowsuser>,pass=<windowspass>

 

The above is a general form, note the need for extra backslashes to escape those characters. A more specific example is using "myusername" is below. This will ask me for my password I hit enter to execute.

 

mount.cifs \\\\myserver\\myshare  /mnt  -o user=myusername

 

Regards

 

Greg Sterling

Highlighted
Ensign

Re: CIFS mount error

HI @gsterling 

 

I have tried with your command but it still fails:

 

backup.png

 

And this server is working for DCE. 😞

Highlighted

Re: CIFS mount error

Hi!

1. Try to add sec parameter to Greg's command

2. Do you have a comma in your password?

In this case you can try to escape it with quotes or put it in credential file (https://linux.die.net/man/8/mount.cifs)

3. You can try to add mount via Webmin:

Go to Webmin - > Disk and Network Filesystems

Choose CIFS from the list, click "Add Mount" button

Fill parameters

Click "Create" button

 

image.pngimage.png

Highlighted
Ensign

Re: CIFS mount error

Hi @Valentin_Kozlov 

 

I tried first with Webmin and it did not work. In the password there is a . (point), not a comma, can this also affect?

 

I am going to try adding sec parameter.

 

Thanks for your support.

Highlighted
Lieutenant JG

Re: CIFS mount error

Hello.

 

Ok, but the error changes when you ran using the syntax I had recommended so that suggests to me we're on the right track.

 

Ok, next steps.

 

Please confirm samba and cifs utils are installed. I assume they are cause you would have different problems.

 

# yum list installed | egrep -e 'samba|cifs'
cifs-utils.x86_64 6.2-10.el7 @anaconda
samba-client-libs.x86_64 4.10.4-11.el7_8 @CentosUpdates
samba-common.noarch 4.10.4-11.el7_8 @CentosUpdates
samba-common-libs.x86_64 4.10.4-11.el7_8 @CentosUpdates
samba-libs.x86_64 4.10.4-11.el7_8 @CentosUpdates

 

Which OS version is the windows share running? Windows 2012, something newer? You may need to add the "vers=" parameter to define the version of SMB you're connecting with.

 

After the user=<USERNAME> parameter add ",vers=2.1"   (note the comma before "vers") to enforce at least SMB version 2.1 during the connection. If your windows server is newer try ",vers=3.0".

 

If neither works, please run the dmesg command so we can see if there are any specific samba log messages in the log output.