Warning
Potential for Data Loss: The steps detailed in the resolution of this article may result in a loss of critical data if not performed properly. Before beginning these steps, make sure all important data is backed up in the event of data loss. If you are unsure or unfamiliar with any complex steps detailed in this article, please contact Product Support for assistance.
Issue
- I/NET SQL database becomes too big affecting the performance of I/NET.
- Backup and restore of the I/NET SQL database take several hours to finish.
Product Line
TAC INET
Environment
- I/NET
- SQL Server
Cause
There are two files for the SQL database for I/NET: InetDb.mdf and InetDb_log.ldf. The InetDb.mdf file is the data files of the database, where all of the tables, indexes (other than full-text catalogs), stored procedures, etc. are stored.
The .mdf is the primary data file for the whole database. While The InetDb_log.ldf is the transaction log. The transaction log is where all transactions are written to. Sometimes it will be the InetDb_log.ldf growing too big. Since it is less important, it can be shrunk without any impact on I/NET operation or any data/events/transactions lost.
Resolution
- Be sure to backup the database first with DBCreate or Microsoft SQL Server Management Studio
- Open the Microsoft SQL Server Management Studio and connect to the database.
- Right click on InetDb and choose Property. Set Recovery model to Simple in the Options.
- Right click on InetDb and choose Tasks-->Shrink-->Files. Choose the File type to Log, and keep the Shrink action in Release unused space.
- Check the file size of InetDb_log.ldf. It should have decreased in size.