Issue
Unable to send emails using Google's SMTP Server
Product Line
Security Expert
Environment
- Security Expert Server
- Security Expert Controllers (SP-C-WEB, SP-C)
- Google SMTP Server
Cause
SMTP server settings in Controller and/or Google account settings are incorrect.
Resolution
- Check that the correct SMTP server address and settings are used:
- SMTP Mail Server: smtp.googlemail.com
- SMTP Port: 25
- Use SSL: Enabled
- If not already set, ensure that the google account being used has "less secure app access" enabled as this is required, the default setting is for this to be disabled. See details on how to change the setting in Google and mentioned in the SP-C-WEB Programming Reference Guide under the Settings | Email section.
GMail Less Secure Access
- Ensure Firewall settings are not blocking access to the mail server, especially if the McAfee firewall is being used. If there is a Firewall try temporarily disabling this to test.