Issue
Getting the Error "The Web Site URL for Reports is not configured. Please contact the administrator"
or "The webpage cannot be found"
Environment
SmartStruxure
Enterprise Server
Reports Server
Web Reports
Cause
You get this error because the link for the Reports Server is not correct.
Having the Enterprise Server and Report Server on the same PC is usually what is causing this issue. It should be noted that this is not the recommended installation method in having both the Enterprise and Report Server's on the same PC.
The reason the Workstation can not access the Web site / Web service URL's is because the Report Manager points to the "Localhost", when you try to use a Workstation that is not local to the Report Server it can not locate this URL, hence the error. Changing this URL to the IP (or PC Name) of the Report Server will fix this. This issue is not seen if using correct installation of having the Report Server on a different machine to the Enterprise Server as designed.
Resolution
Even though the Enterprise Server is local to the Report Server if access required by any other Workstation or WebStation you must enter the IP or PC Name of the Report Server within the Report Manager's Web site URL. In this instance changing only the Web site URL will rectify the problem but it is recommended to change both the Web site and Web Service URL settings. This will allow any remote Workstation / Browser to find the Report Server.
- In workstation, Browse, to the System folder
- Click on System>Report Manager
- Set the Web site URL to http://localhost/SchneiderElectric/WebReports/Login.aspx
- Set the Web Service URL to http://localhost/SchneiderElectric/WebReportsService
- If the Enterprise Server resides on a different PC than the Reports Server, change "localhost" to the Report Server computer name or IP address
After making this change the WebReport should display correctly: