Issue
When creating the ETL task the "Run Once" works, but when configured to run as a service, it doesn't work and an error occurs.
Here is an example of what you will see in the error log:
Environment
- Power Manager
- ETL
Cause
-
When testing the ETL task using "Run Once", the Windows account you are currently logged in with will be used to access the SQL database. When the task is then configured to run as a service, the account configured on the service will be used. By default that account is the built-in account 'NT AUTHORITY\SYSTEM'.
- The Position values for all of the mapped trend logs are set to an unreasonable timestamp. The timestamp is either very old of a data the proceeds the oldest values in the database.
Resolution
Changing the Windows system account for the ETL service
You can either give the system account access to the database, or you can change the account used to run the service.
Correct/Adjust the timestamp values in Positions tab of ETL
The timestamps can be changed all at once by setting the Intital value field at the top of the "Positions" window in the ETL tool.