Issue
Can an alarm be generated if a Niagara R2 Enterprise Server loses connectivity to the Vykon Alarm Service (VAS)?
Environment
- Niagara R2
- VAS client
Cause
To trigger an alarm when VAS connection changes, create a program object and link to clientActive.
Resolution
In order to alarm on the status of a VAS connection, do the following:
Create a program object in WorkPlace Pro, and paste in the following code:
////////////////////////////////////////////////////////////////
// VAS Active clients
// This object monitors the number of active VAS clients.
// Revision History:
// 07 August, 2007
//////////////////////////////////////////////////////////////////
// Inputs
// flex input int ActiveClients
//
// Outputs
// output FloatStatusType Clients
// Processing
Clients.value = ActiveClients
- Link the clientActive property of the VykonAlarmService to the ActiveClients property of the program object
- Create a comparison object, and link the output of the program object to Input A of the comparison object
- In the comparison object, configure the function so that A < B, and set defaultB to 1
- Create a BI object, and link the status out of the comparison object to the status in of the BI
- Configure the alarm properties of the BI