Invite a Co-worker
Send a co-worker an invite to the Exchange portal.Just enter their email address and we’ll connect them to register. After joining, they will belong to the same company.
Send Invite Cancel
80692members
346645posts

XS900 Failures

Solved
yellowairplane_apc
Crewman
Crewman
0 Likes
10
241

XS900 Failures

This was originally posted on APC forums on 6/26/2010


I had three of these on separate circuits powering separate computers and within the the past 4 months all three have died in a very bad way -

Red Overload Light
Buzzing
Immediate Shutdown of Everything

I have other APC-UPS's (different model numbers) as well - they have been working without problem.
Lots of other electronics - nothing else has died.

Is this normal end of life behavior for these products - no protection - just boom, loud buzzing noise and immediate shutdown? The units are all about the same age - and less than 4 or 5 years old? Is that the expected lifetime for these products?

Model/Serial Numbers: BX900 QB0602133451, BX900R JB0630013374, BX900R JB0645006055

Tags (2)

Accepted Solutions
yellowairplane_apc
Crewman
Crewman
0 Likes
0
241

XS900 Failures

This was originally posted on APC forums on 6/26/2010


I had three of these on separate circuits powering separate computers and within the the past 4 months all three have died in a very bad way -

Red Overload Light
Buzzing
Immediate Shutdown of Everything

I have other APC-UPS's (different model numbers) as well - they have been working without problem.
Lots of other electronics - nothing else has died.

Is this normal end of life behavior for these products - no protection - just boom, loud buzzing noise and immediate shutdown? The units are all about the same age - and less than 4 or 5 years old? Is that the expected lifetime for these products?

Model/Serial Numbers: BX900 QB0602133451, BX900R JB0630013374, BX900R JB0645006055

See Answer In Context

10 Replies 10
yellowairplane_apc
Crewman
Crewman
0 Likes
0
241

Re: XS900 Failures

This was originally posted on APC forums on 6/28/2010


All three scenarios are pretty much the same:

* PC + monitor hooked up to 1 of the units
* PC only hooked up to the other 2 units.
* Red light on front of unit comes on indicating overload - APC unit immediately cuts power to PCs (no shutdown, etc).

In terms of configuration:
* Black three pronged NEMA connectors from computer equipment plugged into NEMA Battery Protection circuit receptacle of APC
* Back three pronged NEMA connector from APC plugged into properly grounded outlet with proper polarity.
* Tons of ventilation around each unit. All units kept in temperature maintained spaces.

Those were the only XS900's that I had - all three seem to have been faulty. There are several other posts in this forum describing the exact same behavior for the XS900's ...

I have 5 other APC units running right now (1 going on 6 years old) - no problems yet - none are XS900's (those all died).

yellowairplane_apc
Crewman
Crewman
0 Likes
0
241

Re: XS900 Failures

This was originally posted on APC forums on 6/28/2010


Sorry - forgot to mention:

PC with monitor < 300 W
PCs w/o monitor < 200 W

BillP
Administrator Administrator
Administrator
0 Likes
0
241

Re: XS900 Failures

This reply was originally posted by Angela on APC forums on 6/28/2010


and the overload LED is solid (vs. flashing?)

no other LEDs are on at this time?

yellowairplane_apc
Crewman
Crewman
0 Likes
0
241

Re: XS900 Failures

This was originally posted on APC forums on 7/1/2010


The first XS900 failure happened several months ago - red light came on - swapped the XS900 w/another APC unit - no further issues.

The second XS900 failure happened about 3 months ago - red light came on - Swapped the XS900 w/another APC unit - no further issues.

The third and last XS900 failure happened a few days ago - red light came on - I do not remember any beeping - the APC unit immediately removed all power from the PC and monitors it was serving (made me quite angry - lost work... that's the reason I bought protection - so I would not lose work!). That unit did not get a second chance from me either. I disconnected it and replaced it with another unit - no issues since. After reading your post - I just powered up the last unit without load and it does come on (no red light, no beeping) ... but I no longer trust the unit with computing equipment... so it will soon be headed out for recycling....

That should be the end of my XS900 story as that was all I owned!

Tsunami_apc
Crewman
Crewman
0 Likes
0
241

Re: XS900 Failures

This was originally posted on APC forums on 7/13/2010


I had a similar issue with mine. After a year the fan got really loud and then a few weeks later I got the overload warning light with nothing plugged into the unit. It was replaced under warranty but now the new unit is having the same fan issue.

Tsunami_apc
Crewman
Crewman
0 Likes
0
241

Re: XS900 Failures

This was originally posted on APC forums on 7/14/2010


Mine just died today. I submitted a support ticket.

ghobish_apc
Cadet
0 Likes
0
241

Re: XS900 Failures

This was originally posted on APC forums on 2/4/2012


Now wait a minute... I have an XS900/ BX900 that displays the same symptoms... I bought a new fan from Jameco and disassembled the unit and found... NO FAN!! So I guess I should go ahead and replace the batteries?

dkeith_apc
Cadet
0 Likes
0
241

Re: XS900 Failures

This was originally posted on APC forums on 5/12/2011


my Back UPS XS900 failed just like all the others reported on this site. Turns out it was the 24vdc muffin fan that was the problem. Replaced the muffin fan with one found on E-bay with similar spec's and so far everything is working fine... My gut feeling is that APC knew about this component weakness because of all the feedback on this forum.....

BillP
Administrator Administrator
Administrator
0 Likes
0
241

Re: XS900 Failures

This reply was originally posted by Dakota on APC forums on 10/11/2011


Ya The Cheapy Fan Is The Problem

yellowairplane_apc
Crewman
Crewman
0 Likes
0
242

XS900 Failures

This was originally posted on APC forums on 6/26/2010


I had three of these on separate circuits powering separate computers and within the the past 4 months all three have died in a very bad way -

Red Overload Light
Buzzing
Immediate Shutdown of Everything

I have other APC-UPS's (different model numbers) as well - they have been working without problem.
Lots of other electronics - nothing else has died.

Is this normal end of life behavior for these products - no protection - just boom, loud buzzing noise and immediate shutdown? The units are all about the same age - and less than 4 or 5 years old? Is that the expected lifetime for these products?

Model/Serial Numbers: BX900 QB0602133451, BX900R JB0630013374, BX900R JB0645006055