Invite a Co-worker
Send a co-worker an invite to the Exchange portal.Just enter their email address and we’ll connect them to register. After joining, they will belong to the same company.
Send Invite Cancel
79276members
343947posts

Is my Back-UPS Pro 1500GI dead?

Solved
tomsbyo_apc
Cadet
0 Likes
1
79

Is my Back-UPS Pro 1500GI dead?

This was originally posted on APC forums on 12/10/2015


Have had my BR1500GI for a little more than a year. It was working smoothly up until this morning. 

I switched the unit off at the control panel, but left the power outlet switched on. In the afternoon, during a thunderstorm there was a close strike. Had multiple other appliances switched on at the time with no effect. About 1 minute after the lightning strike the UPS, while still powered off, starts continually making a clicking noise similar to when it switches over to battery. I turned the power off at the outlet. 

Now the unit will not switch back on. With no mains connected the led back lights for the control panel buttons turn on when the power button is pressed, but nothing happens. Total silence. When mains is connected the unit emits a rapid beeping noise when the power button is pressed, but the unit does not boot. In both instances the front panel lcd does not power on.

Have reseated  the battery, but this makes no difference. 

Have pressed the power button for longer than 4secs, but there is either silence or continuous rapid beeping depending on whether mains is plugged in or not.

Have checked the circuit breaker, but it was not tripped. Pressing it makes no difference. 

The surge outlets still work. 

Has this unit developed an internal fault? 

Rgds

Tom 


Accepted Solutions
mitsmith_apc
Lt. Commander
Lt. Commander
0 Likes
0
80

Re: Is my Back-UPS Pro 1500GI dead?

This was originally posted on APC forums on 12/11/2015


Hi Tom,

Unfortunately, it sounds like there might be some internal fault. I would recommend resetting the unit as follows as the last step.

-disconnect the unit from the wall and unplug the battery 

-wait about 30 seconds

-reconnect the battery

-Try turning the unit on via battery power 

If it will not turn on I would expect the the unit has an internal fault. You can try contacting your local support to see if the unit is still covered under warranty.

http://www.schneider-electric.us/sites/us/en/support/faq/faq_main.page?page=content&country=US〈=en&id=FA158815

-Mike

See Answer In Context

1 Reply 1
mitsmith_apc
Lt. Commander
Lt. Commander
0 Likes
0
81

Re: Is my Back-UPS Pro 1500GI dead?

This was originally posted on APC forums on 12/11/2015


Hi Tom,

Unfortunately, it sounds like there might be some internal fault. I would recommend resetting the unit as follows as the last step.

-disconnect the unit from the wall and unplug the battery 

-wait about 30 seconds

-reconnect the battery

-Try turning the unit on via battery power 

If it will not turn on I would expect the the unit has an internal fault. You can try contacting your local support to see if the unit is still covered under warranty.

http://www.schneider-electric.us/sites/us/en/support/faq/faq_main.page?page=content&country=US〈=en&id=FA158815

-Mike