Invite a Co-worker
Send a co-worker an invite to the Exchange portal.Just enter their email address and we’ll connect them to register. After joining, they will belong to the same company.
Send Invite Cancel
79372members
344102posts

BX1300G incorrectly reporting battery needs replacement

Solved
braindead0_apc
Crewman
Crewman
0 Likes
6
204

BX1300G incorrectly reporting battery needs replacement

This was originally posted on APC forums on 1/12/2012


As soon as the new year clicked over, my brand new BX1300G started reporting that the battery needs replacement, even though all tests indicate the battery is fine. I'm running this primarily on a *nix box with APCUPSD, however this morning I installed the latest powerchute on my netbook and connected up to it, everything reports fine. Used the 'replace battery' function to make sure everything was setup (date, etc).. that didn't help, UPS still thinks it needs a new battery.

Sounds like a bug in the data compare code, firmware line on this is "864.L5 .D USB FW:L5"

Anybody found a battery date that will make this work properly?


Accepted Solutions
braindead0_apc
Crewman
Crewman
0 Likes
0
204

Re: BX1300G incorrectly reporting battery needs replacement

This was originally posted on APC forums on 1/12/2012


It's the firmware on the UPS that's reporting battery needs replacement, and it doesn't appear to be due to self-test as when I run a self-test from the user level software it reports the self-test completed without errors. Thus my theory that this is incorrectly reported.

The manufacture date is March 13 2011.

Message was edited by: braindead0

See Answer In Context

6 Replies 6
BillP
Administrator Administrator
Administrator
0 Likes
0
204

Re: BX1300G incorrectly reporting battery needs replacement

This reply was originally posted by Chris on APC forums on 1/12/2012


Is the software saying it failed a battery test or that it needs a new battery? The difference is that the software will "recommend" you replace the battery based on that battery date which is either from install or when you replaced the battery or when you updated it using the replace battery date button.

braindead0_apc
Crewman
Crewman
0 Likes
0
205

Re: BX1300G incorrectly reporting battery needs replacement

This was originally posted on APC forums on 1/12/2012


Status from APCUPSD is ONLINE REPLACEBATT

It has not failed any self tests I've performed, nor reported any failed tests. Battery voltage is 27.0V which should be fine for 2 12v batteries.

barryware_apc
Lieutenant JG
Lieutenant JG
0 Likes
0
205

Re: BX1300G incorrectly reporting battery needs replacement

This was originally posted on APC forums on 1/12/2012


I have a BX1000G that acts up once in a while.. My solution:

turn off
disconnect from AC
remove battery
let sit for a couple of minutes
install battery
connect to AC
turn on

braindead0_apc
Crewman
Crewman
0 Likes
0
205

Re: BX1300G incorrectly reporting battery needs replacement

This was originally posted on APC forums on 1/12/2012


Seems like a poor situation for a UPS.. But worth a try I suppose. Thanks for the suggestion.

I just looked back at my logs and found this started on January 10th, I thought I had an email alert on the 1st but was mistaken.

BillP
Administrator Administrator
Administrator
0 Likes
0
205

Re: BX1300G incorrectly reporting battery needs replacement

This reply was originally posted by Chris on APC forums on 1/12/2012


Well all that really does is force it to do another self test. Is this failure via the software is not as result of a self test, this test won't do anything. The software doesn't know the battery is failing unless it fails a self test. How old is the UPS/battery?

braindead0_apc
Crewman
Crewman
0 Likes
0
205

Re: BX1300G incorrectly reporting battery needs replacement

This was originally posted on APC forums on 1/12/2012


It's the firmware on the UPS that's reporting battery needs replacement, and it doesn't appear to be due to self-test as when I run a self-test from the user level software it reports the self-test completed without errors. Thus my theory that this is incorrectly reported.

The manufacture date is March 13 2011.

Message was edited by: braindead0