Invite a Co-worker
Send a co-worker an invite to the Exchange portal.Just enter their email address and we’ll connect them to register. After joining, they will belong to the same company.
Send Invite Cancel
80791members
346835posts

BF 350 On Battery after power restored

Solved
jdmada_apc
Crewman
Crewman
0 Likes
2
107

BF 350 On Battery after power restored

This was originally posted on APC forums on 5/31/2010


Lost house power today and turned off BF 350 when beeping started and unit went to battery power. When power restored unit remains in battery mode, I have a continuous tone and will not reset despite repeated UPS power cycling and completely removing power to the UPS. Battery is only 18 months old and registers about 13.7v. Does battery just need to recharge?

Tags (4)

Accepted Solutions
jdmada_apc
Crewman
Crewman
0 Likes
0
107

BF 350 On Battery after power restored

This was originally posted on APC forums on 6/1/2010


Lost house power today and turned off BF 350 when beeping started and unit went to battery power. When power restored unit remains in battery mode, I have a continuous tone and will not reset despite repeated UPS power cycling and completely removing power to the UPS. Battery is only 18 months old and registers about 13.7v. Does battery just need to recharge?

See Answer In Context

2 Replies 2
DeltaV_Master_apc
Cadet
0 Likes
0
107

Re: BF 350 On Battery after power restored

This was originally posted on APC forums on 6/1/2010


Hi jmada.

Did you buy the battery new or used? Some batteries will continuously run on recharge because they never reach full rated amps. I'm thinking if you got it brand new, UPS should replace it as it may be a defective part. If you got it used you could be s.o.l. 13.7 V sounds pretty sluggish.

Good luck

jdmada_apc
Crewman
Crewman
0 Likes
0
108

BF 350 On Battery after power restored

This was originally posted on APC forums on 6/1/2010


Lost house power today and turned off BF 350 when beeping started and unit went to battery power. When power restored unit remains in battery mode, I have a continuous tone and will not reset despite repeated UPS power cycling and completely removing power to the UPS. Battery is only 18 months old and registers about 13.7v. Does battery just need to recharge?