Invite a Co-worker
Send a co-worker an invite to the Exchange portal.Just enter their email address and we’ll connect them to register. After joining, they will belong to the same company.
Send Invite Cancel
79290members
343968posts

APC Back-UPS XS 1500 - Powerchute Reinstall Problems

Solved
slickplaid_apc
Crewman
Crewman
0 Likes
30
684

APC Back-UPS XS 1500 - Powerchute Reinstall Problems

This was originally posted on APC forums on 10/3/2008


I am trying to upgrade/fix my current install of Powerchute. I am currently having problems with it detecting my UPS with it connected via RJ45>USB cable.

When I attempt to reinstall it with the most recent version of the software on the website, it gives me several errors:

First it will report this error:

---------------------------
APC PowerChute Personal Edition Setup
---------------------------
A previous version of APC PowerChute® Personal Edition has been found but InstallShield® is unable to determine which version.

Do you wish to uninstall this version of APC PowerChute® Personal Edition?
---------------------------
Yes No
---------------------------

Next, after I click yes and proceed to uninstall the current program, it gives me this error even though I have plenty of disk space left:

---------------------------
APC PowerChute Personal Edition Setup
---------------------------
There is not enough disk space to uninstall APC PowerChute® Personal Edition. Please clean up some disk space and try again.
---------------------------
OK
---------------------------
I click OK and it proceeds to uninstall anyways, but hangs on "Re-Enabling Windows Native Power Management" and the "IKernel" process sits at a constant 25% of process usage (which I assume is because I have a quad-core processor and it's not multi-threaded, otherwise it'd be at 100%).

Now, I attempt to reinstall again without removing the previous version and nothing happens, the window disappears and no apparent processes are still running in the task manager.

I have attempted this process in Safe Mode, running the process as an administrator, running it as a regular user, deleting the contents of the c:\program files\apc\*, deleting the files in the C:\Users\*\AppData\Roaming\*, C:\Users\*\AppData\Local\*, and manually deleting the service with nothing but the same result.

My next steps are to strace the output of installing the program on a different machine to be able to remove all registry entries and any other files it dumps outside of it's install folders, but I'm trying here first.

Am I missing something important here or what exactly is going on? I would think I could just wipe the program by deleting it from the program file directory (and any cached files in the user directory) but it still comes up that it is already installed.

Here are some system specs:
Vista 32-bit, 4gb ram, 0.5tb raid0+1 hdd0(4) (230gb free), several other hdds
1000w PSU, logitech g15 keyboard, g9 mouse connected
Powerchute.exe displays Product and File version at 2,0,0,0
Status cable connected to a properly powered USB port directly to the mobo, not a usb hub. RJ45>USB


Accepted Solutions
BillP
Administrator Administrator
Administrator
0 Likes
0
684

Re: APC Back-UPS XS 1500 - Powerchute Reinstall Problems

This reply was originally posted by Angela on APC forums on 10/3/2008


it sounds like you may have installed powerchute personal edition 2.0 for XP which doesnt work correctly for vista.

if its ok with you, confirm your email is correct and i can send you some manual uninstall instructions to remove it. then, you can get the correct version of powerchute personal edition for windows vista which is version 2.1.1 located here (if its not already what you are trying to install):

ftp://ftp.apcc.com/apc/public/software/windows/vista/pcpe/211/PowerChutePersonalEdition.exe

after that, we can see if everything is back to normal.

See Answer In Context

30 Replies 30
chrisromer_apc
Cadet
0 Likes
0
684

Re: APC Back-UPS XS 1500 - Powerchute Reinstall Problems

This was originally posted on APC forums on 1/27/2010


You can only have BE or PE installed? I really wish they had one client to check all types. I've got different units all over the place I need to check with a laptop.

Please send manual uninstall. Why not just post the instructions?

slickplaid_apc
Crewman
Crewman
0 Likes
0
684

APC Back-UPS XS 1500 - Powerchute Reinstall Problems

This was originally posted on APC forums on 10/3/2008


I am trying to upgrade/fix my current install of Powerchute. I am currently having problems with it detecting my UPS with it connected via RJ45>USB cable.

When I attempt to reinstall it with the most recent version of the software on the website, it gives me several errors:

First it will report this error:

---------------------------
APC PowerChute Personal Edition Setup
---------------------------
A previous version of APC PowerChute® Personal Edition has been found but InstallShield® is unable to determine which version.

Do you wish to uninstall this version of APC PowerChute® Personal Edition?
---------------------------
Yes No
---------------------------

Next, after I click yes and proceed to uninstall the current program, it gives me this error even though I have plenty of disk space left:

---------------------------
APC PowerChute Personal Edition Setup
---------------------------
There is not enough disk space to uninstall APC PowerChute® Personal Edition. Please clean up some disk space and try again.
---------------------------
OK
---------------------------
I click OK and it proceeds to uninstall anyways, but hangs on "Re-Enabling Windows Native Power Management" and the "IKernel" process sits at a constant 25% of process usage (which I assume is because I have a quad-core processor and it's not multi-threaded, otherwise it'd be at 100%).

Now, I attempt to reinstall again without removing the previous version and nothing happens, the window disappears and no apparent processes are still running in the task manager.

I have attempted this process in Safe Mode, running the process as an administrator, running it as a regular user, deleting the contents of the c:\program files\apc\*, deleting the files in the C:\Users\*\AppData\Roaming\*, C:\Users\*\AppData\Local\*, and manually deleting the service with nothing but the same result.

My next steps are to strace the output of installing the program on a different machine to be able to remove all registry entries and any other files it dumps outside of it's install folders, but I'm trying here first.

Am I missing something important here or what exactly is going on? I would think I could just wipe the program by deleting it from the program file directory (and any cached files in the user directory) but it still comes up that it is already installed.

Here are some system specs:
Vista 32-bit, 4gb ram, 0.5tb raid0+1 hdd0(4) (230gb free), several other hdds
1000w PSU, logitech g15 keyboard, g9 mouse connected
Powerchute.exe displays Product and File version at 2,0,0,0
Status cable connected to a properly powered USB port directly to the mobo, not a usb hub. RJ45>USB

camphill_apc
Cadet
0 Likes
0
684

Re: APC Back-UPS XS 1500 - Powerchute Reinstall Problems

This was originally posted on APC forums on 8/20/2010


Can you email me the manual uninstall steps. I too have these same issues.

Thanks

BillP
Administrator Administrator
Administrator
0 Likes
0
684

Re: APC Back-UPS XS 1500 - Powerchute Reinstall Problems

This reply was originally posted by Gary on APC forums on 11/9/2008


Thanks!

BillP
Administrator Administrator
Administrator
0 Likes
0
684

Re: APC Back-UPS XS 1500 - Powerchute Reinstall Problems

This reply was originally posted by Angela on APC forums on 3/3/2009


please take a look at this thread:

Referenced content removed

cswolfe_apc
Cadet
0 Likes
0
684

Re: APC Back-UPS XS 1500 - Powerchute Reinstall Problems

This was originally posted on APC forums on 2/13/2009


Having the same problems as the others. The old catch 22. XP sees the device as "unknown," powershute won't recognize the UPS, and therefore won't install. USB to PCI device driver, current version, correctly installed.

One more request for manual install instructions, please, via e-maill. GREATLY appreciated. Thank you!

UPDATE: I've tried everything from every thread, and still to no avail. BIOS settings are correct. No APM, legacy support enabled.

sigh. Drivers installed are the correct and current version of Standard USB to PCI, and have are absolutely installed correctly. (undid and redid it just to be sure), as well. Rebooted the UPS.

I still like the product ... and I'll still buy APC, as I always have, but I gotta say, to take several hours to try to get this going, still to no avail, is a real pain in the a$$.

The bottom line remains the same. Unplug and replug in the rj45 to USB, straight into my system (which I hate, but I can live with), and the same "unknown device" message comes up, despite the fact that the correct drivers are installed.

THANK YOU for getting out of this bottomless APC pit, which I've never had on any computer other than this current one, and I do mean current -- as in absolutely nothing in it approaching obsolescence, and 3 month old ASUS motherboard.

Message was edited by: cswolfe

Message was edited by: cswolfe

BillP
Administrator Administrator
Administrator
0 Likes
0
684

Re: APC Back-UPS XS 1500 - Powerchute Reinstall Problems

This reply was originally posted by Gary on APC forums on 11/8/2008


Hi, I'm having the exact same problem as the original poster with trying to uninstall the older version. Could you send me the manual uninstall instructions as well?

Thanks!

BillP
Administrator Administrator
Administrator
0 Likes
0
684

Re: APC Back-UPS XS 1500 - Powerchute Reinstall Problems

This reply was originally posted by Angela on APC forums on 11/9/2008


Sent.

jaymz_apc
Cadet
0 Likes
0
684

Re: APC Back-UPS XS 1500 - Powerchute Reinstall Problems

This was originally posted on APC forums on 3/3/2009


Hi there,

I am having the same issues as the orignal poster (execpt on windows 2000)

Can you please send me the removal instructions too?

Thanks in advance
James

BillP
Administrator Administrator
Administrator
0 Likes
0
684

Re: APC Back-UPS XS 1500 - Powerchute Reinstall Problems

This reply was originally posted by Jonathan on APC forums on 8/20/2010


Hi Tim,

Can you tell us what software did you install and the operating system that you have?

rrivest_apc
Cadet
0 Likes
0
684

Re: APC Back-UPS XS 1500 - Powerchute Reinstall Problems

This was originally posted on APC forums on 3/8/2013


Can you send me the manual uninstall steps as well?  I am running Windows 7 64-bit

BillP
Administrator Administrator
Administrator
0 Likes
0
684

Re: APC Back-UPS XS 1500 - Powerchute Reinstall Problems

This reply was originally posted by Jonathan on APC forums on 3/11/2013


I have sent a PM to your Inbox rrivest

slickplaid_apc
Crewman
Crewman
0 Likes
0
684

Re: APC Back-UPS XS 1500 - Powerchute Reinstall Problems

This was originally posted on APC forums on 10/3/2008


Okay, I've done some testing on the cable and it seems that the second connector from the left isn't carrying a signal. I'm going to see if I can't find the short or gap in the cable and fix it.

slickplaid_apc
Crewman
Crewman
0 Likes
0
684

Re: APC Back-UPS XS 1500 - Powerchute Reinstall Problems

This was originally posted on APC forums on 10/3/2008


Alright! A little solder and some electrical tape and it's fixed!

The install went smoothly and I'm having no more problems.

Moral of the story is to always test your cables first.

Thank you both for your help in solving my problem!

BillP
Administrator Administrator
Administrator
0 Likes
0
684

Re: APC Back-UPS XS 1500 - Powerchute Reinstall Problems

This reply was originally posted by Angela on APC forums on 10/3/2008


if you hate looking at the tape, i'd be happy to send you a new cable 🙂

yes i have learned from this as well - i rarely see a cable fix an issue. first for everything though!

have a good weekend.

slickplaid_apc
Crewman
Crewman
0 Likes
0
684

Re: APC Back-UPS XS 1500 - Powerchute Reinstall Problems

This was originally posted on APC forums on 10/3/2008


Also, apologies if I posted this in the wrong forum. It does not list the "XS" in either the PC/Workstation or the Network/Server forum descriptions, so I assumed it was workstation grade.

slickplaid_apc
Crewman
Crewman
0 Likes
0
684

Re: APC Back-UPS XS 1500 - Powerchute Reinstall Problems

This was originally posted on APC forums on 10/3/2008


No reason to do that, although I really appreciate the offer. It looks like the cable had been pulled out a little bit from the plastic rj45 cable crimp due to it being pushed up against the wall. Once I have a chance to grab a crimp tool from work and a replacement plastic head it'll be trivial to fix and it'll look just like new.

Once again, thanks. 🙂

BillP
Administrator Administrator
Administrator
0 Likes
0
685

Re: APC Back-UPS XS 1500 - Powerchute Reinstall Problems

This reply was originally posted by Angela on APC forums on 10/3/2008


it sounds like you may have installed powerchute personal edition 2.0 for XP which doesnt work correctly for vista.

if its ok with you, confirm your email is correct and i can send you some manual uninstall instructions to remove it. then, you can get the correct version of powerchute personal edition for windows vista which is version 2.1.1 located here (if its not already what you are trying to install):

ftp://ftp.apcc.com/apc/public/software/windows/vista/pcpe/211/PowerChutePersonalEdition.exe

after that, we can see if everything is back to normal.

slickplaid_apc
Crewman
Crewman
0 Likes
0
684

Re: APC Back-UPS XS 1500 - Powerchute Reinstall Problems

This was originally posted on APC forums on 10/3/2008


My email is correct and I await your direction.

I did install this almost immediately after Vista came out, so I'm guessing that it's very possible that was the version I had downloaded.

Thanks for the quick response!

BillP
Administrator Administrator
Administrator
0 Likes
0
684

Re: APC Back-UPS XS 1500 - Powerchute Reinstall Problems

This reply was originally posted by Angela on APC forums on 10/3/2008


i will email those instructions to you momentarily 🙂

slickplaid_apc
Crewman
Crewman
0 Likes
0
684

Re: APC Back-UPS XS 1500 - Powerchute Reinstall Problems

This was originally posted on APC forums on 10/3/2008


I just tried it on my laptop, which does not have hibernation disabled and it fails to detect the device. (should have tried this to begin with)

Faulty RJ45>USB cable? or Faulty RJ45 jack on the UPS?

laptop: vista 32bit, 4gb ram, no ups software installed

Message was edited by: slickplaid

slickplaid_apc
Crewman
Crewman
0 Likes
0
684

Re: APC Back-UPS XS 1500 - Powerchute Reinstall Problems

This was originally posted on APC forums on 10/3/2008


Okay, I've manually uninstalled the program and now it does not hang on installation, but I am having problems with it detecting my UPS via USB.

The USB cable is attached but now it displays the device as an unknown device before I try and install the software you listed above.

When I do attempt to install it, it gave me the error that it couldn't find the USB device. Now it's giving me this:

---------------------------
APC PowerChute Personal Edition
---------------------------
This operating system is not supported. Please visit www.apc.com for details of products for your platform.
---------------------------
OK
---------------------------

When I plug in the device, it tells me that there is an error with the unknown device (as there is no driver assoc. with it). Where can I find the driver?

I will also re-download the software and try a couple more things.

I am searching through the forums for an acceptable answer, but it seems like a lot of the people who have had this problem with the Back-UPS XS 1500 (for whatever reason it has a label underneath that calls it BX1500LCD) just got frustrated and gave up.

Referenced content removed
Referenced content removed
Referenced content removed <- I am not using any of those mobos

Following these FAQ's:

http://nam-en.apc.com/cgi-bin/nam_en.cfg/php/enduser/std_adp.php?p_faqid=905

Attempting to manually add the drivers ("Standard Universal PCI to USB Host Controller". ) using the above faq leads me to "This device cannot start. (code 10)"
Also, the motherboard is relatively new and supports USB keyboards, mice, so I'm not sure that would be an issue.


http://nam-en.apc.com/cgi-bin/nam_en.cfg/php/enduser/std_adp.php?p_faqid=2923
Do you see listings as ?Batteries? and ?Human Interface Device?? I do not see any "Battery" listings, and when I insert the USB, it still comes up with an error after following this FAQ.


http://nam-en.apc.com/cgi-bin/nam_en.cfg/php/enduser/std_adp.php?p_faqid=1645
If communication between the PC and the USB compatible Back-UPS, is not working properly when the cable is first connected, an "Unknown Device" is detected. This problem may be the result of a weak USB receiver on the PC side. If the UPS itself is not detected when the cable is connected (i.e., its not detecting a "Back UPS Pro 350", the installation of APC's Power Management Extensions or Powerchute Personal Edition may fail or hang after the setup.exe file is executed.
This seems a little bit more on track, but I don't have any other problems with my other USB devices. I'm going to attempt to plug it into each USB slot to see if it displays something different.

I have unplugged every USB device, and tried it in every USB slot with no success on any of them.
I have uninstalled the driver before unplugging, and then reinserting the USB device.
I have restarted my computer after uninstalling it, unplugging it, then rebooting with no effect.
Every time, it still comes up with "Unknown Device"

I believe what I'm looking for is some kind of HID-compliant device?

Also, after I re-downloaded the program, it now just says it can't find my device via USB. I believe why it said something about the operating system, is after it failed it asked if I wanted to reinstall with alternative settings.

Is there anything else I can try?

Message was edited by: slickplaid

BillP
Administrator Administrator
Administrator
0 Likes
0
684

Re: APC Back-UPS XS 1500 - Powerchute Reinstall Problems

This reply was originally posted by Angela on APC forums on 10/3/2008


it seems like you are doing everything correctly.

just for the heck of it, have you tried rebooting the UPS?

slickplaid_apc
Crewman
Crewman
0 Likes
0
684

Re: APC Back-UPS XS 1500 - Powerchute Reinstall Problems

This was originally posted on APC forums on 10/3/2008


No, I haven't.

I'll have to shut down my computer and try that since it's plugged into the UPS.

Be back again soon. 🙂

slickplaid_apc
Crewman
Crewman
0 Likes
0
684

Re: APC Back-UPS XS 1500 - Powerchute Reinstall Problems

This was originally posted on APC forums on 10/3/2008


I have just rebooted the unit (and my computer) and it still shows up as an unknown device.

I've even gone as far as uninstalling EVERY HID device and reinstalling it.

No luck on anything so far.

I'm running out of ideas, any thing else I can try?

BillP
Administrator Administrator
Administrator
0 Likes
0
684

Re: APC Back-UPS XS 1500 - Powerchute Reinstall Problems

This reply was originally posted by Angela on APC forums on 10/3/2008


do you have another machine to try it on before we assume its something on the computer when it is really an issue with the UPS?

usually, with the UPS plugged in and uninstalling the HID device or unknown device that it shows up as works so that when you reinsert the USB cable, it installs correctly.

hidclass.sys, hidparse.sys, hidusb.sys, hid.dll, pid.dll - are you able to find these all on your system?

TheNotoriousKMP_apc
Sisko
Sisko
0 Likes
0
684

Re: APC Back-UPS XS 1500 - Powerchute Reinstall Problems

This was originally posted on APC forums on 10/3/2008


Here's what another customer stated, not sure if it will entirely apply to your situation, but other customers having software issues have said this is helpful:

PROBLEM SOLVED -
OK, here it is for posterity.

Just to be thorough, I plugged in the APC UPS as normal, let Windows do it's thing, then installed PowerChute.
I rebooted for extra measure.
APC PowerChute warned me that HIBERNATION was not enabled, so I enabled it.
I rebooted.
I uninstalled and the problem was still there.
At this time the APC is NOT plugged in to my PC.

SOLUTION -
I went into Device Manager.
I chose to select and UNINSTALL anything APC related under BATTERIES.
I rebooted.
However, I noticed that under HID(Human Interface Device), the APC USB UPS item was still there!
I manually UNINSTALLED that with a right click. It disappeared.
I rebooted.
Plugged the APC UPS into the USB port. Windows found it. Installed it.
And Tah-Dah....under Power Options, the battery/native UPS tweaking had returned.

I repeated this on the other PC and all worked exactly once again.

So, basically,
1 - Make sure there is nothing APC related under the Device Manager.
2 - Reboot.
3 - Double check for APC items in Device manager to be sure.
4 - Plug in APC UPS unit and all should be well.

slickplaid_apc
Crewman
Crewman
0 Likes
0
684

Re: APC Back-UPS XS 1500 - Powerchute Reinstall Problems

This was originally posted on APC forums on 10/3/2008


As administrator:
---------------------------
APC PowerChute Personal Edition Setup
---------------------------
The installer is unable to locate a supported APC battery backup connected to your computer.

Please check your USB connections and try again.
---------------------------
OK
---------------------------



Attempting to install in compatability mode (winxp sp2):
---------------------------
APC PowerChute Personal Edition
---------------------------
This operating system is not supported. Please visit www.apc.com for details of products for your platform.
---------------------------
OK
---------------------------


I'm going to extract the files from the *.exe and see if I can't find a driver in there.
Nope, just says that I have the most up-to-date driver installed, "Unknown Device".

-----

I'm going to re-enable hibernation, see if that fixes anything.

BillP
Administrator Administrator
Administrator
0 Likes
0
684

Re: APC Back-UPS XS 1500 - Powerchute Reinstall Problems

This reply was originally posted by Angela on APC forums on 10/3/2008


hibernation shouldnt have anything to do with this. i believe those instructions were more so after we get beyond the point that we are at.

i dont suppose you noticed anything physically wrong with the cable? if not, i wouldnt suspect the cable as the culprit unless its obviously damaged. i'd assume it was the UPS more so.

how long have you had the UPS?

PS the software i linked you to above is for Vista only so i wouldnt expect it to work in compatibility mode on XP. the UPS needs to be detected by vista first before installing the APC PCPE software.

jonesbasf_apc
Cadet
0 Likes
0
684

Re: APC Back-UPS XS 1500 - Powerchute Reinstall Problems

This was originally posted on APC forums on 1/3/2010


Hey there. Another genius that tried to install BE over PE. Any chance I can get the manual uninstall directions? My email address is up to date.

Brad