Invite a Co-worker
Send a co-worker an invite to the Exchange portal.Just enter their email address and we’ll connect them to register. After joining, they will belong to the same company.
Send Invite Cancel
79433members
344191posts

SNMP v3 SETUP

Solved
BillP
Administrator Administrator
Administrator
0 Likes
6
219

SNMP v3 SETUP

This question was originally posted by Paul on APC forums on 4/20/2008


Has anyone got snmp v3 working on their pdu?

I have the following settings:

1. User Name: power
2. Authentication phrase : powerapc
3. Encryption phrase: powerapc
4. Access Type: Auth/NoPriv

Access is enabled for v3

Then using a call like:
snmpwalk -v 3 -u power -l authNoPriv -a MD5 -A powerapc -c public 156.241.33.110 -m "./powernet367.mib" PowerNet-MIB::apc

produces:
snmpwalk: Authentication failure (incorrect password, community or key)


I've set it up correctly and to me it looks like it should work. Has anyone got v3 snmp running ? I'm using

Rack PDU APP v3.5.6
Network Management Card AOS v3.5.7


Kind Regards

Paul

Message was edited by: moetman

Message was edited by: moetman


Accepted Solutions
TheNotoriousKMP_apc
Sisko
Sisko
0 Likes
0
219

Re: SNMP v3 SETUP

This was originally posted on APC forums on 4/24/2008


Paul,

The one thing we were discussing and which I'm still unclear of, is that you were using the Public community string name in the original setup, but yet your Config.ini file also has it as private.

So now I'm at a point where I'm sort of confused as to where the problem lies.

We know we solved the problem with the Auth. phrase, but what's left other than the community string?

See Answer In Context

6 Replies 6
BillP
Administrator Administrator
Administrator
0 Likes
0
219

Re: SNMP v3 SETUP

This reply was originally posted by Paul on APC forums on 4/21/2008


Yea that's set to 'Enabled' as well - still getting Authentication problems.

voidstar_apc
Janeway
Janeway
0 Likes
0
220

Re: SNMP v3 SETUP

This was originally posted on APC forums on 4/21/2008


One little gotcha I've run into is that not only does access need to be enabled for SNMPv3 but also for the user profile in the "access control" section. It defaults to disabled.

TheNotoriousKMP_apc
Sisko
Sisko
0 Likes
0
220

Re: SNMP v3 SETUP

This was originally posted on APC forums on 4/22/2008


Paul,

I received some information from a fellow moderator who has more in-depth SNMP knowledge than I possess...

Can you post your config.ini here?

Have you upgraded to version 3.5.8 on the PDU FW?
Have you upgraded to version 3.9.1 on the MIB (This I assume you have since I provided that link for another issue earlier)?
What NMS are you using?
Where are you inputting the authentication? We tried to replice with "powerapc" as the authentication phrase, except it requires the phrase to be 13 characters.

Is it possible for you to post your .ini file so that we can take a look at it, possibly upload it to one of our PDU's running the same FW and try the same thing you're trying by duplicating your v3 settings?

I broke it down like this:

snmpwalk -v 3
-u power Username
-l authNoPriv I don't know what this is*
-a MD5 Authentication Type
-A powerapc Auth Phrase (Too Short)
-c public 156.241.33.110 Community String (You're using the SNMP V1 Comm. String)
-m "./powernet367.mib" PowerNet-MIB::apc



Thanks.

TheNotoriousKMP_apc
Sisko
Sisko
0 Likes
0
220

Re: SNMP v3 SETUP

This was originally posted on APC forums on 4/23/2008


Paul,

In the interest of the size, can you just edit your last post, and just attach your config.ini to the post? It's easier for me to download/view that way.

You stated changing the length of the Auth phrase helped. Just so I'm clear, what problem beyond that are you now facing?

BillP
Administrator Administrator
Administrator
0 Likes
0
220

Re: SNMP v3 SETUP

This reply was originally posted by Paul on APC forums on 4/24/2008


No Problems - attached the config.ini.

Thanks and Best Regards

TheNotoriousKMP_apc
Sisko
Sisko
0 Likes
0
220

Re: SNMP v3 SETUP

This was originally posted on APC forums on 4/24/2008


Paul,

The one thing we were discussing and which I'm still unclear of, is that you were using the Public community string name in the original setup, but yet your Config.ini file also has it as private.

So now I'm at a point where I'm sort of confused as to where the problem lies.

We know we solved the problem with the Auth. phrase, but what's left other than the community string?