Invite a Co-worker
Send a co-worker an invite to the Exchange portal.Just enter their email address and we’ll connect them to register. After joining, they will belong to the same company.
Send Invite Cancel
80634members
346598posts

PCPE 2.2 install can't locate SUA1000 connected by USB to PC w Vista 64bit

Solved
tomski_apc
Crewman
Crewman
0 Likes
14
744

PCPE 2.2 install can't locate SUA1000 connected by USB to PC w Vista 64bit

This was originally posted on APC forums on 2/6/2010


I downloaded PCPE 2.2 for Vista from the APC website. The PCPE 2.2 installer tries to disable the Windows native power management system. It then shows an error message, "The installer is unable to locate an APC battery backup connected to your computer..."

After reading many APC knowledge base and forum querries, I attached the USB cable from the SUA1000 to a root hub on the back of the PC. I also performed "braindeading" on the SUA1000.

When I look at the Windows device manager on my PC, I see the APC UPS identified in three locations:

1. Under Batteries, it's shown as an HID UPS Battery
2. Under HIDs, it's shown as an HID APC USB UPS
3. Under USB Controllers, under Root Hubs, it's shown as an HID UPS Battery (APC USB UPS)

No matter what I try, the PCPE installer cannot locate the APC SUA1000 Smart UPS, and thus aborts the installation.

My PC is a one-year-old Dell Studio XPS 435MT Desktop, with an Intel i7-920 processor, running Windows Vista Home Premium, SP2, 64-bit, OS. I'm using a brand new USB 2.0 A to B cable.

Can anyone help? Thanks!


Accepted Solutions
robinb_apc
Ensign
Ensign
0 Likes
0
744

Re: PCPE 2.2 install can't locate SUA1000 connected by USB to PC w Vista 64bit

This was originally posted on APC forums on 7/26/2017


Sorry to resurrect an old thread but I have exactly the same problem.

Just purchased a 2nd user APC SUA1000I

I have a windows XP computer.

I only want to check the settings which have been installed. (i do not want to manage anything, just check and confirm settings as per user manual, it does mention the personal software in there.)

I have tried both personal and business powerchute software but it does not see the ups on istallation.

Windows XP does see the UPS in Battery and HID (but not usb hub).

Any ideas please ?

thanks

See Answer In Context

14 Replies 14
tomski_apc
Crewman
Crewman
0 Likes
0
744

Re: PCPE 2.2 install can't locate SUA1000 connected by USB to PC w Vista 64bit

This was originally posted on APC forums on 2/7/2010


Voidstar: Great response. Thanks a ton! The PCBE install was a snap.

tomski_apc
Crewman
Crewman
0 Likes
0
744

PCPE 2.2 install can't locate SUA1000 connected by USB to PC w Vista 64bit

This was originally posted on APC forums on 2/7/2010


I downloaded PCPE 2.2 for Vista from the APC website. The PCPE 2.2 installer tries to disable the Windows native power management system. It then shows an error message, "The installer is unable to locate an APC battery backup connected to your computer..."

After reading many APC knowledge base and forum querries, I attached the USB cable from the SUA1000 to a root hub on the back of the PC. I also performed "braindeading" on the SUA1000.

When I look at the Windows device manager on my PC, I see the APC UPS identified in three locations:

1. Under Batteries, it's shown as an HID UPS Battery
2. Under HIDs, it's shown as an HID APC USB UPS
3. Under USB Controllers, under Root Hubs, it's shown as an HID UPS Battery (APC USB UPS)

No matter what I try, the PCPE installer cannot locate the APC SUA1000 Smart UPS, and thus aborts the installation.

My PC is a one-year-old Dell Studio XPS 435MT Desktop, with an Intel i7-920 processor, running Windows Vista Home Premium, SP2, 64-bit, OS. I'm using a brand new USB 2.0 A to B cable.

Can anyone help? Thanks!

robinb_apc
Ensign
Ensign
0 Likes
0
745

Re: PCPE 2.2 install can't locate SUA1000 connected by USB to PC w Vista 64bit

This was originally posted on APC forums on 7/26/2017


Sorry to resurrect an old thread but I have exactly the same problem.

Just purchased a 2nd user APC SUA1000I

I have a windows XP computer.

I only want to check the settings which have been installed. (i do not want to manage anything, just check and confirm settings as per user manual, it does mention the personal software in there.)

I have tried both personal and business powerchute software but it does not see the ups on istallation.

Windows XP does see the UPS in Battery and HID (but not usb hub).

Any ideas please ?

thanks

robinb_apc
Ensign
Ensign
0 Likes
0
744

Re: PCPE 2.2 install can't locate SUA1000 connected by USB to PC w Vista 64bit

This was originally posted on APC forums on 7/26/2017


It shows up as version 3.02 on download

Attachments
BillP
Administrator Administrator
Administrator
0 Likes
0
744

Re: PCPE 2.2 install can't locate SUA1000 connected by USB to PC w Vista 64bit

This reply was originally posted by Bill on APC forums on 7/27/2017


Hi,

PowerChute Personal Edition is only compatible with Back-UPS. For a Smart-UPS SUA you should install PowerChute Business Edition Agent and use the web interface to access the UPS. The latest version compatible with Windows XP is PCBE 9.1.1 It can be downloaded from here by clicking download https://schneider-electric.box.com/s/2jlitrlgdwvtk061x9kblh2q8mx1et66. Another option for Windows XP is APCUPSD

robinb_apc
Ensign
Ensign
0 Likes
0
744

Re: PCPE 2.2 install can't locate SUA1000 connected by USB to PC w Vista 64bit

This was originally posted on APC forums on 7/27/2017


Thanks Bill

I did try the business edition yesterday and that could not see the UPS. (like the personal one).

The 2nd link you mentioned goes to a dead page.

robinb_apc
Ensign
Ensign
0 Likes
0
744

Re: PCPE 2.2 install can't locate SUA1000 connected by USB to PC w Vista 64bit

This was originally posted on APC forums on 7/27/2017


Bill, forgot to ask.

You mentioned Web interface ?

How is that done, I thought the interaction was done via the application (which wont install as it cant see the UPS). ?

BillP
Administrator Administrator
Administrator
0 Likes
0
744

Re: PCPE 2.2 install can't locate SUA1000 connected by USB to PC w Vista 64bit

This reply was originally posted by Bill on APC forums on 7/27/2017


Hi,

Sorry the system added forums.apc.com to the link that is incorrect. Enter apcupsd.org as the url and you will gain access. 

As for PowerChute not recognizing the UPS, you mentioned that HID UPS drivers were loading. Check out this FAQ on how to switch the driver to APC UPS USB driver http://www.apc.com/us/en/faqs/FA164514

PowerChtue will not recognize the UPS until the APC UPS drivers are loaded. 

robinb_apc
Ensign
Ensign
0 Likes
0
744

Re: PCPE 2.2 install can't locate SUA1000 connected by USB to PC w Vista 64bit

This was originally posted on APC forums on 7/27/2017


Thanks

Will let you know how it works out.

robinb_apc
Ensign
Ensign
0 Likes
0
744

Re: PCPE 2.2 install can't locate SUA1000 connected by USB to PC w Vista 64bit

This was originally posted on APC forums on 7/27/2017


Hi

Ok, I got the APCUPSD software to run on my mac and I could see the ups and its settings.

However I could not see a way of changing settings (like battery change date, self test period etc ) all as per user manual.

On my windows XP machine I installed the powerchute software and it did install after I changed the driver to APC.

However after I installed that, not sure what I am doing as it wants me to set up user accounts / email address etc. and I could not get it show the UPS attached in the software as it was trying to find a network connection.

Is there a simple way to update some of the user selectable options ?

BillP
Administrator Administrator
Administrator
0 Likes
0
744

Re: PCPE 2.2 install can't locate SUA1000 connected by USB to PC w Vista 64bit

This reply was originally posted by Bill on APC forums on 7/27/2017


Hi,

On 7/27/2017 11:14 AM, robin said:

Ok, I got the APCUPSD software to run on my mac and I could see the ups and its settings.

However I could not see a way of changing settings (like battery change date, self test period etc ) all as per user manual.

Those settings are in the apcupsd.conf file as described in the User's Guide. http://www.apcupsd.org/manual/manual.html

Battery date is under the heading of BATTDATE and SELFTEST

On 7/27/2017 11:14 AM, robin said:

However after I installed that, not sure what I am doing as it wants me to set up user accounts / email address etc. and I could not get it show the UPS attached in the software as it was trying to find a network connection.

Where are you being asked to create and account and enter email? When installing the PowerChute Agent you should be asked to enter a user name and password but not create an account and the installer would not ask for email address. As for the network is the Windows XP system configured with a network connection? PowerChute Agent needs the system to be configured with an IP address to allow access to the Agent web interface. 

It might be helpful to see screenvshots of the issue to help diagnose the issue/s 

robinb_apc
Ensign
Ensign
0 Likes
0
744

Re: PCPE 2.2 install can't locate SUA1000 connected by USB to PC w Vista 64bit

This was originally posted on APC forums on 7/27/2017


thanks again Bill

I could not find details on configuration file for apcupsd on my mac, the file did not appear to exist.

However I ran again the BE of powerchute on my VM machine on my mac and I got in.

The xp version on an old laptop was not playing ball.

Can say its particularly user friendly with having to goto multiple menus to adjust things but I did reset battery install data and self test interval.

I could not see anywhere in the software regarding firmware update, if one is available, in acpupsd  it said firmware was 1.5 (from memory), is there an update available ?

And how do I get / install ?

many thanks

BillP
Administrator Administrator
Administrator
0 Likes
0
744

Re: PCPE 2.2 install can't locate SUA1000 connected by USB to PC w Vista 64bit

This reply was originally posted by Bill on APC forums on 7/28/2017


Hi,

There are no firmware updates for SUA model Smart-UPS.

robinb_apc
Ensign
Ensign
0 Likes
0
744

Re: PCPE 2.2 install can't locate SUA1000 connected by USB to PC w Vista 64bit

This was originally posted on APC forums on 7/28/2017


Thanks for your help Bill