Invite a Co-worker
Send a co-worker an invite to the Exchange portal.Just enter their email address and we’ll connect them to register. After joining, they will belong to the same company.
Send Invite Cancel
79139members
343562posts

AP9630 NMC2 notification sending problem

Solved
rcoate_apc
Ensign
Ensign
0 Likes
18
428

AP9630 NMC2 notification sending problem

This was originally posted on APC forums on 4/6/2015


We're having a strange problem with all of our AP9630 NMC2 that are running firmware v6.x.   We have them configured to send e-mail notifications for all events.  Although the notifications are being sent successfully, the message being sent is always one event behind the actual event that occurred.

 

For example, if I log in via telnet/CLI, a notification of the login should be sent.  Instead, the notification contains the message of the previous event, which might have been (for example) an NTP update that occurred the day before.  When I log out, the login notification will be sent (one event behind what actually occurred).  The next day, when a self-test runs, the first notification message will be the logout from the day before.

 

We tried updating to the latest v6.2.1, but the problem continues.

 

We do not have this problem on any NMC2 running v5.x. 

 

Has anyone else had this problem?  Any chance that it will be fixed in the next firmware release? 

 

Thanks in advance for any help!

 


Accepted Solutions
rcoate_apc
Ensign
Ensign
0 Likes
0
428

Re: AP9630 NMC2 notification sending problem

This was originally posted on APC forums on 1/12/2016


Thanks very much!  I tried the new firmware on one of our problem units, and confirmed that it resolves the sending / notification problem.

See Answer In Context

18 Replies 18
BillP
Administrator Administrator
Administrator
0 Likes
0
428

Re: AP9630 NMC2 notification sending problem

This reply was originally posted by Angela on APC forums on 4/6/2015


Hi Robert,

I had logged a bug on this a few months ago and have brought visibility to it. It is on the top of my own personal list to drive to resolution. Not everyone sees this issue but I have not heard of a root cause yet. I also haven't been able to figure out what the commonality is across everyone who sees it. I will add your information to our bug detail and continue to voice the urgency on getting this resolved.

For reference, here is another thread on the issue: http://forums.apc.com/spaces/7/ups-management-devices-powerchute-software/forums/general/10465/ap963... and I think there maybe another one somewhere.

rcoate_apc
Ensign
Ensign
0 Likes
0
428

Re: AP9630 NMC2 notification sending problem

This was originally posted on APC forums on 4/6/2015


Thanks for your reply and for your attention to this problem.  Glad to see it is getting some attention.

rcoate_apc
Ensign
Ensign
0 Likes
0
428

Re: AP9630 NMC2 notification sending problem

This was originally posted on APC forums on 6/9/2015


Since a fix doesn't seem to be coming any time soon, how would we go about downgrading to a prior firmware version?  It seems that 6.1.1 is OK and does not have the e-mail / notification bug.  Anything 6.2 or later has the problem.  Only 6.2.1 is available on the support web site, is there some way to get the earlier versions and to apply them as a downgrade?  Can I use FTP to extract the needed files from an NMC2 card running 6.1.1 and apply them to a card currently running 6.2.1?

 

 

rcoate_apc
Ensign
Ensign
0 Likes
0
428

Re: AP9630 NMC2 notification sending problem

This was originally posted on APC forums on 6/9/2015


Minor correction to last post:  6.1.1 *does* seem to have the bug.  How do we downgrade to 5.x?

rcoate_apc
Ensign
Ensign
0 Likes
0
428

Re: AP9630 NMC2 notification sending problem

This was originally posted on APC forums on 6/24/2015


Hi Angela,

Thanks for attaching the v517 files for the NMC2 downgrade.  I read through the support articles you referenced, and I **think** I understand the downgrade process as follows:

 

1)  Use FTP to transfer the AOS file first.  QUESTION: What happens to the v611 AOS file, do I have to manually delete it?  QUESTION:  Do I have to manually initiate a reboot of the NMC2 card, or is that somehow automatic?

2)  Use FTP to transfer the sumx file.  QUESTIONS:  Same as above, do I have to manually delete the v611 sumx file, and do I have to manually reboot the management card?

3)  Format (wipe flash) and reconfigure all settings.

 

Thanks for your help with these questions.

 

 

 

 

 

BillP
Administrator Administrator
Administrator
0 Likes
0
428

Re: AP9630 NMC2 notification sending problem

This reply was originally posted by Angela on APC forums on 6/25/2015


Hi Robert,

1.) Yes, all you need to do is FTP new AOS. The card does the rest including knowing to reboot when AOS transfer is complete.

2.) Yes, all you need to do is FTP the APP second. Same as above regarding reboot.

3.) Yes, do that after - you're correct.

BillP
Administrator Administrator
Administrator
0 Likes
0
428

Re: AP9630 NMC2 notification sending problem

This reply was originally posted by IFI on APC forums on 9/4/2015


Hi,

I'm experiencing the same issue, but on AP9537SUM Network Card. Is there any update about the solution. Can I find firmware upgrade for my product? (on website I just foud firmware for AP9630/9631 models).

Thank you in advance,

Federico

ijadmin_apc
Cadet
0 Likes
0
428

Re: AP9630 NMC2 notification sending problem

This was originally posted on APC forums on 10/13/2015


Hi Angela,

We are experiencing this issue at 2 of our 6 locations.  I would be happy to post logs or send you anything else that might help.  Otherwise, if there's any update to this problem, can you share?

Thanks!

-Matt

BillP
Administrator Administrator
Administrator
0 Likes
0
428

Re: AP9630 NMC2 notification sending problem

This reply was originally posted by Angela on APC forums on 10/13/2015


Hi Matt,

I checked into the bug I had logged earlier this year. From what I am hearing and seeing, we have resolved the issue with any NMC2 applications that have AOS (APC OS) 6.3.3 or higher. This will start being released for a few different applications late this year/early next year. If you can tell me which specific applications you have (Smart-UPS, Rack PDU, Symmetra, etc), I can possibly give you a more specific ETA. (The newest AOS out there as "final" today I think is only AOS 6.3.2 for certain applications.)

ijadmin_apc
Cadet
0 Likes
0
428

Re: AP9630 NMC2 notification sending problem

This was originally posted on APC forums on 10/15/2015


On 10/13/2015 5:56 PM, Angela said:

Hi Matt,

I checked into the bug I had logged earlier this year. From what I am hearing and seeing, we have resolved the issue with any NMC2 applications that have AOS (APC OS) 6.3.3 or higher. This will start being released for a few different applications late this year/early next year. If you can tell me which specific applications you have (Smart-UPS, Rack PDU, Symmetra, etc), I can possibly give you a more specific ETA. (The newest AOS out there as "final" today I think is only AOS 6.3.2 for certain applications.)

Sure thing.  We're using Smart-UPS with the AP9630.

Thanks!

-Matt

BillP
Administrator Administrator
Administrator
0 Likes
0
428

Re: AP9630 NMC2 notification sending problem

This reply was originally posted by Joel on APC forums on 11/7/2015


This issue sounds similar if not the same problem as:

http://forums.apc.com/spaces/7/ups-management-devices-powerchute-software/forums/general/10687/ap963....

This seems to effect the transmission of e-mails period.  Also access to the Management console as well.

I am awaiting since March for these issues to be resolved, with no news.  Waiting for FW update for my 9630's (Smart-UPS)

rcoate_apc
Ensign
Ensign
0 Likes
0
428

Re: AP9630 NMC2 notification sending problem

This was originally posted on APC forums on 12/30/2015


Any news on an AOS 6.3.3 release for AP9630 NMC2 on Smart UPS 2200?  It seems to be available only for the Symmetra.

ijadmin_apc
Cadet
0 Likes
0
428

Re: AP9630 NMC2 notification sending problem

This was originally posted on APC forums on 1/4/2016


I just tested the latest 6.4 firmware and it fixed this issue for us.

ezbrezzy_apc
Crewman
Crewman
0 Likes
0
428

Re: AP9630 NMC2 notification sending problem

This was originally posted on APC forums on 1/5/2016


Hi Angela,

Do you possibly have the release notes/bug fixes for V6.4.0? 

BillP
Administrator Administrator
Administrator
0 Likes
0
428

Re: AP9630 NMC2 notification sending problem

This reply was originally posted by Angela on APC forums on 1/5/2016


Hi,

I don't see the final copy yet. It is in the last stages of release/cleaning. Potentially why the download hasn't been posted yet since they will be posted as well.

Some high level fixes/enhancements off the top of my head:

  • Add support for TLS v1.2 HTTPS web access
  • Add ability for user to select "minimum" SSL/TLS protocol they wish to use i.e. disable SSLv3
  • Remove weak cipher suites
  • Default SSL cert uses SHA-2 signature
  • Responsive web UI
  • Modbus TCP output
  • Email delayed by one issue mentioned here
  • .csf files (for user management) not parsed when uploaded via SCP (documented here)
  • Fixed issues with OpenSSH v6.7 and higher 
  • Various UPS specific issues that I can't recall
  • Fix for latency/network/ping response time in environments with moderate-high network traffic
  • Fix for web access issues outside local subnet (documented here)

If you have a specific question/issue you want to know about, I can check into it.

ezbrezzy_apc
Crewman
Crewman
0 Likes
0
428

Re: AP9630 NMC2 notification sending problem

This was originally posted on APC forums on 1/5/2016


Thanks!

BillP
Administrator Administrator
Administrator
0 Likes
0
428

Re: AP9630 NMC2 notification sending problem

This reply was originally posted by Angela on APC forums on 1/11/2016


Firmware now posted! I made a post on this site here with links and FYIs: http://forums.apc.com/spaces/7/ups-management-devices-powerchute-software/forums/general/11714/fyi-u... 

rcoate_apc
Ensign
Ensign
0 Likes
0
429

Re: AP9630 NMC2 notification sending problem

This was originally posted on APC forums on 1/12/2016


Thanks very much!  I tried the new firmware on one of our problem units, and confirmed that it resolves the sending / notification problem.